Closed Bug 891035 Opened 6 years ago Closed 6 years ago

Flash fullscreen video crashes

Categories

(Core :: Plug-ins, defect, critical)

20 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla25
Tracking Status
firefox22 --- wontfix
firefox23 --- verified
firefox24 --- verified
firefox25 --- verified

People

(Reporter: akeybl, Assigned: aklotz)

References

()

Details

(Keywords: crash, regression, reproducible)

Crash Data

Attachments

(1 file)

From Yahoo - "we are seeing Firefox 22 crashing on windows 7 in certain scenarios when we full screen some of the videos running under flash plugin"

Currently #108 but rising, and may happen frequently in certain user scenarios. Worth looking into.

https://crash-stats.mozilla.com/report/index/21990bfd-be81-4228-a91b-2d8a62130707 does have comments that can be used for reproduction
Crash Signature: [@ RtlpCallQueryRegistryRoutine | RtlDeregisterWaitEx | UnregisterWaitEx ]
Better steps to reproduce, Flash versions, and whether the crash reproduces in FF21 would all help (from the original Yahoo reporter).
It's related to the plugin hang UI based on the stack trace.
This signature is only on Windows 7 but there might be a Vista and Win 8 versions.

(In reply to Alex Keybl [:akeybl] from comment #0)
> https://crash-stats.mozilla.com/report/index/21990bfd-be81-4228-a91b-
> 2d8a62130707 does have comments that can be used for reproduction
It's an uncommon GPU:
AdapterVendorID: 0x15ad, AdapterDeviceID: 0x0405: VMWare Player 3.1.6 Software Driver
Severity: normal → critical
Component: General → Plug-ins
OS: Mac OS X → Windows 7
Product: Firefox → Core
Yeah, we've had known issues running Flash under VMs. But regardless, the plugin hang UI shouldn't be crashing ;-). aklotz can you take a look? I seem to remember a race condition that we fixed, but I'm not sure which release it landed in.
Assignee: nobody → aklotz
I'm testing out a patch right now.
Hi Alex and Team,
thanks for promptly looking into it.

Here are the steps to reproduce:
Windows PC, Firefox 21, flash version 11.7.700


1. go to: http://news.yahoo.com/woman-drinks-only-soda-16-years-suffers-heart-111020462.html

2. click on small video within article

3. Video starts playing in light box experience.

4. try and view it in full screen when video is playing and it crashes.

This is happening on both FF 21 and FF22.
I get a Run Time Error, R6025 pure virtual function call, then the Flash crash prompt and the plugin hang prompt: bp-359e0754-540f-4088-8ec0-562c82130708.
Blocks: F1398665248
Crash Signature: [@ RtlpCallQueryRegistryRoutine | RtlDeregisterWaitEx | UnregisterWaitEx ] → [@ RtlpCallQueryRegistryRoutine | RtlDeregisterWaitEx | UnregisterWaitEx ] [@ F1398665248_____________________________ ]
Attached patch Mutex PatchSplinter Review
The problem is clearly indicated in the crash report by the two stacks simultaneously calling UnregisterWaitEx().

This patch adds a mutex to broaden the scope of mutual exclusion for state changes that occur when Plugin Hang UI cleanup occurs concurrently with a response from the Plugin Hang UI child process.

I've tested this patch against the STR and against Plugin Hang UI regression tests. Note that the "pure virtual function call" dialog comes from the Flash Player, so that doesn't go away with this patch. We'll have to reach out to Adobe to get that fixed.

Try build is
https://tbpl.mozilla.org/?tree=Try&rev=8b34a7e6a331
Attachment #772916 - Flags: review?(benjamin)
Not a Firefox 22 regression and not yet a topcrash. We'd consider a low risk uplift to beta, but no need to track for upcoming releases.
(In reply to Aaron Klotz [:aklotz] from comment #7)
> Note that the "pure virtual function call" dialog comes from the
> Flash Player, so that doesn't go away with this patch. We'll have to reach
> out to Adobe to get that fixed.

Filed bug 891813.
No longer blocks: F1398665248
Crash Signature: [@ RtlpCallQueryRegistryRoutine | RtlDeregisterWaitEx | UnregisterWaitEx ] [@ F1398665248_____________________________ ] → [@ RtlpCallQueryRegistryRoutine | RtlDeregisterWaitEx | UnregisterWaitEx ]
Attachment #772916 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/0c0da58f7950
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Comment on attachment 772916 [details] [diff] [review]
Mutex Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 805591
User impact if declined: Browser crash under certain conditions. Not currently a topcrash.
Testing completed (on m-c, etc.): Tested using STR, regression tests, and already landed on m-c
Risk to taking this patch (and alternatives if risky): Low, the problem is well understood and the fix is narrow in scope and straightforward.
String or IDL/UUID changes made by this patch: None.
Attachment #772916 - Flags: approval-mozilla-beta?
Attachment #772916 - Flags: approval-mozilla-aurora?
Blocks: 805591
Keywords: regression
Version: unspecified → 20 Branch
Attachment #772916 - Flags: approval-mozilla-beta?
Attachment #772916 - Flags: approval-mozilla-beta+
Attachment #772916 - Flags: approval-mozilla-aurora?
Attachment #772916 - Flags: approval-mozilla-aurora+
I can't reproduce the crash, neither with Firefox 21 nor 22, using the STR from comment 5.

All I get is a Run Time Error, R6025 pure virtual function call, and then the Flash crash prompt.

While checking the crash stats from Socorro, regarding last month, there are 17 crashes on 23.0b6, 9 crashes on 24.0a2, and 6 crashes on 25.0a1:

https://crash-stats.mozilla.com/report/list?signature=RtlpCallQueryRegistryRoutine+%7C+RtlDeregisterWaitEx+%7C+UnregisterWaitEx&product=Firefox&query_type=contains&range_unit=weeks&process_type=any&version=Firefox%3A22.0&hang_type=any&date=2013-07-19+09%3A00%3A00&range_value=4
QA Contact: manuela.muntean
(In reply to Manuela Muntean [:Manuela] [QA] from comment #14)
> While checking the crash stats from Socorro, regarding last month, there are
> 17 crashes on 23.0b6, 9 crashes on 24.0a2, and 6 crashes on 25.0a1
The patch landed in 23.0b7 and I don't see crashes after 24.0a2/20130716 and 25.0a1/20130707.
(In reply to Scoobidiver from comment #15)
> (In reply to Manuela Muntean [:Manuela] [QA] from comment #14)
> > While checking the crash stats from Socorro, regarding last month, there are
> > 17 crashes on 23.0b6, 9 crashes on 24.0a2, and 6 crashes on 25.0a1
> The patch landed in 23.0b7 and I don't see crashes after 24.0a2/20130716 and
> 25.0a1/20130707.

Indeed. Also, no crashes with 23.0b7, so I'm marking this as verified fixed.
No crashes using the STR in comment 5.
Also there are no recent crashes based on the crash stats.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.