Closed Bug 891049 Opened 6 years ago Closed 6 years ago

[Skia] Disable building Skia on big endian platforms

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: gw280, Assigned: gw280)

References

Details

Attachments

(1 file)

Big endian isn't an officially supported platform upstream, and as far as I'm aware, none of our big endian ports are actually using Skia anyway, so we should just disable it from being built.
Attachment #773395 - Flags: review?(matt.woodrow)
Attachment #773395 - Flags: review?(matt.woodrow) → review?(khuey)
Just voicing some discussion that was had in the Toronto office on Bugzilla... The reason I ended up whitelisting x86/arm instead of disabling BE is that really, the platforms that upstream tests against regularly are x86 and arm and not other configurations. Whilst other platforms are "supported", there's no real guarantee that they won't be broken. As the usage of Skia in Firefox for non-x86/arm platforms is pretty much non-existent, I think it's wise to only enable building it on x86/arm.
Duplicate of this bug: 890530
https://hg.mozilla.org/mozilla-central/rev/0bf9cd2343d7
Assignee: nobody → gwright
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
See Also: → 1144632
You need to log in before you can comment on or make changes to this bug.