M7 does not render empty <body> tags

VERIFIED FIXED in M8

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: sirtwist, Assigned: pierre)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
I've found that M7 does not render pages with no text (or ASCII whitespace) between <body> and </body>.
Machine: Beige G3/233, 64 MB RAM, OS 8.6

Updated

20 years ago
Assignee: don → rickg
Component: Browser-General → Layout

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

20 years ago
I created a test case like this: <HTML><BODY></BODY></HTML> and the content
model was correctly formed. When the reporter of this bug says nothing renders,
isn't that exactly what one would expect? I need more info if I'm to do anything
with this bug.
(Reporter)

Comment 2

20 years ago
Try this test case:



<html><body bgcolor="#000000"></body></html>



This renders as either grey or white. However, if there is any printable content,

it will render as a black screen.

Updated

20 years ago
Assignee: rickg → pierre
Status: ASSIGNED → NEW

Comment 3

20 years ago
Pierre -- it appears as though the content model on this one is fine on windows.
Please take a look as to why we don't render correctly.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

20 years ago
It looks like this problem has been fixed (I even noticed it myself about 6 weeks
ago and forgot to file a bug report - thanks for doing it). I can't reproduce it
with today's build of Viewer and Apprunner using both the HTML snippet and the
URL above.

Closed as fixed.

Updated

19 years ago
Component: Layout → HTML Form Controls
QA Contact: leger → phillip
Target Milestone: M8

Comment 5

19 years ago
phillip, could you Verify please?

Comment 6

19 years ago
Created attachment 958 [details]
testcase with red background specified

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
to regress:

1. load attatchment in apprunner.

expected behavior:
	background of this empty document will be red.

actual behavior (as of below builds):
	background is red.

marking verified on

     1999-07-21-08 RedHat Linux 5.2 (GNOME/enlightenment) (Apprunner)
     1999-07-21-08 WinNT 4.0 sp4 (Apprunner)
     1999-07-21-08 MacOS 8.51 (Apprunner)
You need to log in before you can comment on or make changes to this bug.