using tab for a list item inside table cell, doesn't go to next cell

VERIFIED DUPLICATE of bug 92287

Status

()

Core
Editor
P3
minor
VERIFIED DUPLICATE of bug 92287
17 years ago
17 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [keybnd] [QAHP])

(Reporter)

Description

17 years ago
using 7/2 build of netscape

1) launch netscape
2) launch composer
3) insert 2 x 2 table
4) insert a list item in a cell
5) Now hit tab

we should put the caret in the next cell.
Instead, we shift the list item over to the right.

So TAB is overloaded. It has different behavior for following
scenarios:

a) list item inside a table cell
b) single item list
c) multiple item list

Comment 1

17 years ago
we may want to provide a different shortcut for list nesting and leave tab for 
cell navigation. But, how far up the tree would we be expected to crawl to 
determine if the caret is within a cell? For example -- if the list is within a 
blockquote, within a cell and the user hits the tab key -- what should happen?

Updated

17 years ago
Severity: normal → minor
Priority: -- → P3
Whiteboard: [keybnd]
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

17 years ago
I personally believe using Tab for cell-to-cell navigation is a "bad thing" in
a word processor. I'd prefer to see constency of tab usage in lists and change
the key for navigating in tables, but experience tells me this is a minority
position. I'd like to use Ctrl+Enter for "next cell" in tables and
Shift+Ctrl+Enter for "previouse cell" *all the time* for more consistency in
key usage. But we've had "historical/hysterical" conflicts with using Ctrl+Enter
for "Send Message" (see bug 20336).
(Reporter)

Comment 3

17 years ago
also: 

If I press Tab in a table cell, the focus should goto the next cell. Instead the
editor inserts spaces in the cell.

marking bug 93137 a DUP of this one.
(Reporter)

Updated

17 years ago
Whiteboard: [keybnd] → [keybnd] [QAHP]
(Reporter)

Comment 4

17 years ago
*** Bug 93137 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
-->cmanske
Assignee: beppe → cmanske
(Assignee)

Comment 6

17 years ago
All tab behavior / tab in table, etc. will be fixed at one time for bug 92287

*** This bug has been marked as a duplicate of 92287 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.