Closed Bug 891182 Opened 11 years ago Closed 11 years ago

Defect - Top sites selection missing hide/restore buttons

Categories

(Firefox for Metro Graveyard :: App Bar, defect)

25 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: Samvedana, Assigned: sfoster)

References

Details

(Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=0)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130707 Firefox/25.0
Build ID: 20130707031138
Tested for iteration-9 on Windows 8.1 preview using latest nightly build from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-07-03-11-38-mozilla-central/
I used same steps given in user story.

For Top Sites tiles, I can see Pin/Unpin,but I can not see Hide/Restore buttons.

For Bookmarks and History tiles, I can see Hide and Delete buttons.
Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=0
Component: General → App Bar
Summary: Defect- Firefox Start screen context app bar → Defect - Top sites selection missing hide/restore buttons
I'll look into this. I actually do see both Pin and Hide(Delete) buttons for top sites, but I see Unpin for history tiles that aren't pinned which is not right either.
QA Contact: sfoster
Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=0 → feature=defect c=firefox_start u=metro_firefox_user p=1
The pin/unpin on bookmarks and history tiles work differently from top sites which is  pretty confusing. By default, everything is considered pinned, which just means they can show up on start screen. Unpinning will keep the item but not show them on start. Delete removes it completely obviously. This is how pin/unpin work on win8 start screen.

The panel UI was the way to re-pin items back to start screen. It's now gone, making the difference between unpinning and deleting that unpinned items are still shown under 'your results' when you search.

The pinning behavior on topsites makes sense for topsites because they're dinamicly positioned, history and bookmarks are ordered by creation date and a pinning behavior similar to topsites would be strange.

Maybe we need 2 different metaphors here?

Actually, since snapped is using panel UI, it displays all items, irrespective of pinning state. This will be handled by 892073.

Yuan, what do you think?
Flags: needinfo?(ywang)
Assignee: nobody → sfoster
QA Contact: sfoster
I can't reproduce the issue Samvedana described. I've attached a screenshot: for both bookmarks and history tiles, I get both the (X) delete icon and the unpin icon.
(In reply to Rodrigo Silveira [:rsilveira] from comment #2)
> The pin/unpin on bookmarks and history tiles work differently from top sites
> which is  pretty confusing. By default, everything is considered pinned,
> which just means they can show up on start screen. Unpinning will keep the
> item but not show them on start. Delete removes it completely obviously.
> This is how pin/unpin work on win8 start screen.
> 
> The panel UI was the way to re-pin items back to start screen. It's now
> gone, making the difference between unpinning and deleting that unpinned
> items are still shown under 'your results' when you search.
> 
> The pinning behavior on topsites makes sense for topsites because they're
> dinamicly positioned, history and bookmarks are ordered by creation date and
> a pinning behavior similar to topsites would be strange.
> 
> Maybe we need 2 different metaphors here?
> 
> Actually, since snapped is using panel UI, it displays all items,
> irrespective of pinning state. This will be handled by 892073.
> 
> Yuan, what do you think?

I agree we shouldn't use "Pin"/"Unpin" for bookmark and history tiles. There needs to be a different metaphor, probably "Hide". 
And I don't think we need a "Restore/Undo" action after "hide". "Restore" should be shown after "Delete".

If that makes sense, we need to make a new icon for "Hide". Also, we talked about this before, we need to replace the "X" with a trash can icon for "Delete" action. 

Sam, could you add captions for the icons in contextual app bar. Stephen has specified a few in the mockup before, I believe. Thx!
Flags: needinfo?(ywang)
(In reply to Sam Foster [:sfoster] from comment #3)
> Created attachment 774347 [details]
> Screenshot of delete,unpin buttons when selecting a bookmark tile
> 
> I can't reproduce the issue Samvedana described. I've attached a screenshot:
> for both bookmarks and history tiles, I get both the (X) delete icon and the
> unpin icon.

Hi Sam,
According to success scenario in Bug 831914 which is as below:

1. The Metro Firefox user opens Firefox to the Firefox Start screen and sees several tile groups she'd like to interact with.
2. The user selects a tile using the pull down gesture and sees the tile selected and the Firefox Start screen context app bar animate into view.
3. The user examines the app bar and sees options relevant to the selected tile
   a. For Top Sites tiles, the user sees Pin/Unpin, Hide/Restore buttons with   labels -- Story Pin, unpin, hide, and restore a Top Site 
   b. For Bookmarks and History tiles, the user sees Hide and Delete buttons with labels -- Story Hide and delete tiles in Bookmarks and History tile groups 

Actual result:-
Actually, I am getting same result as your attached screenshot for all tiles (Top Sites tiles,Bookmarks and History tiles).

From above success scenario, I though that when I select Top site tile I should see Pin/Unpin, Restore button, but I was not able to see restore button.

I just checked it again and I see restore button once I delete Top site tile in Metro Firefox.
Making One change for comment5

I see pin icon for Top Sites tile, if it is not pinned.

For Bookmarks and Recent History tile, I see unpinned icon.
Samvedana, ah I see the confusion. Once you have used the (X) button to remove a tile (it actually adds it to the a blocked list so it gets filtered out) all the buttons in the the context bar should be replaces with a single undo button. This restores the tile (removes it from block list and repopulates the grid). We did iterate a bit on the interaction with this so that success scenario from the user story is now misleading.

Asa, can you update the story? Then we can close this one out as invalid.
Flags: needinfo?(asa)
Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=1 → feature=defect c=firefox_start u=metro_firefox_user p=0
Yes. The story needs updated and this can be closed as invalid.
Flags: needinfo?(asa)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: