[Settings] Month align of Date select is not good

RESOLVED DUPLICATE of bug 891170

Status

P1
normal
RESOLVED DUPLICATE of bug 891170
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title : Month align of Date select is not good 
2. Precondition : After flashing
3. Tester's Action : In FTU or Settings app - Select Date & Time
  1) Month align is right at first. (find attachment with "Date_picker.png")
  2) Select time picker and then reselect date picker. (find attachment with "Date_picker_after.png")
4. Detailed Symptom : 
5. Expected : 
6. Reproducibility: Y
   - Frequency Rate : 100%
7.Gaia Master/v1-train : v1-train reproduced
8. Version Info
Gaia : 0d5a9a7577f16b6a72a982148c6f509ee1714ea2
Gecko : 499c1f8ea7ad0cdaa7086214278e2944b8a2ea33
(Reporter)

Comment 1

5 years ago
Created attachment 772609 [details]
Date_picker
(Reporter)

Comment 2

5 years ago
Created attachment 772610 [details]
Date_picker_after

Comment 3

5 years ago
It's a wrong width for month.

apps/system/style/value_selector/spin_date_picker.css

#spin-date-picker .value-picker-month-wrapper {
  position: absolute;
  width: -moz-calc(100% - 127px);
  height: 100%;
  top: 10em;
  left: 0px; /* 54px -> 0px */
}

I will upload the patch soon
it seems a dup of bug 891170 , and I think it's already fixed in master branch.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891170

Comment 6

5 years ago
Then, need to land in v1-train. Please check it.
You need to log in before you can comment on or make changes to this bug.