Setting user agent to Mozilla/4.0 causes Java plugin to fail to start

VERIFIED DUPLICATE of bug 83376

Status

defect
VERIFIED DUPLICATE of bug 83376
18 years ago
9 years ago

People

(Reporter: vwdowns, Assigned: edburns)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

()

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 5.5; Windows 95
BuildID:    2001062823

When prefs.js has a line like the following:

user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 5.5;
Linux)");

the Java plugin exits (taking the browser down as well) with the message:

Expected a version > 5! Version = 4

The Java plugin should not depend on the user agent string to know what version
of browser it is running in, since that may need to be faked to work with sites
which expect a Mozilla/4.0 browser.


Reproducible: Always
Steps to Reproduce:
1. Change prefs.js to have a Mozilla/4.0 version
2. Install Java plugin
3. Try to load browser from a shell window.  Watch for the error message

Actual Results:  After installing Java plugin, browser fails to start.  Plugin
produces above error message.  Changing the version back to Mozilla/5.0 works,
but then certain sites will block your client (expecting Mozilla/4.0 instead).

Expected Results:  The Java plugin for Mozilla shouldn't care what the user
agent string says.  It should use other means to determine the browser version
it is running in.
This is not Mozilla's fault I think, but sun's java plugin
moving to oji
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 83376 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.