cannot install facebook from french facebook pages

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: florian, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(platform-rel ?, firefox22 affected, firefox23 affected, firefox24 affected, firefox25 affected)

Details

(Whiteboard: [platform-rel-Facebook])

(Reporter)

Description

6 years ago
I was doing some testing with a nightly with a new profile and needed to enable Facebook messenger. I typed "facebook messenger firefox" in Google.

The first result was:
https://fr-fr.facebook.com/about/messenger-for-firefox

Clicking on the "Activer" (activate) button on this page just disables the button and nothing else seem to happen.

The browser console shows:
[16:40:18.951] [Exception... "'Error: Cannot install provider without manifest data' when calling method: [nsIRunnable::run]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]

The issue doesn't happen if I use https://www.facebook.com/about/messenger-for-firefox instead.
This is caused by a combination of two items.

- we check the install origin (fr-fr.facebook.com) against the origins of builtin prefs, which doesn't recognize the builtin pref since the builtin is www.facebook.com.
- facebook does not send the manifest in the activation event (they are the only provider using the old mechanism)

We can probably get a fix from facebook for the second item, but I think the first is still an issue we should see if we can somehow address.
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox25: --- → affected
Summary: "cannot install provider without manifest data" error when activating Facebook Messenger from the French page → cannot install facebook from french facebook pages
Whiteboard: [platform-rel-Facebook]
platform-rel: --- → ?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.