All users were logged out of Bugzilla on October 13th, 2018

APN settings broken (for Koodo)

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: hub, Assigned: hub)

Tracking

({regression})

unspecified
x86_64
Linux
regression

Firefox Tracking Flags

(b2g-v1.1hd fixed)

Details

(Whiteboard: [c= s=2013.07.12])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This an Eng build (ie I did myself) for Keon.

With the official build 1.0.1, I get "TELUS" as the carrier name (bad, see bug 878948), and in the APN settings I have two choices, including "Koodo" to select. And it work by selecting it - the default selection is wrong, but that's almost no surprise.


On this Eng build, I have "Koodo" displayed as a carrier (good) but if I go into the settings to set the APN, I have no predefined choice of APN only "(custom settings)" and empty fields.

This is 1.2.0.0-prerelease
platform is 25.0a1
Build identifier 20130708131906 (but since I made it, not sure it make sense)
gaia is 530e1b568d1797a991ce23f2ee6702dd55227586
gecko is 6f550edf45533d7b14a53974bbb0cb7cca599e6b
(Assignee)

Comment 1

5 years ago
Even if it displays "TELUS" now for the carrier this is happening. 

Koodo is listed in gaia/shared/resources/apn.json, so there is no reason why it wouldn't be listed.
(Assignee)

Comment 2

5 years ago
With nightly-images-keon-2013-07-08.Gecko-25943da.Gaia-b0d12a6.zip I have the same problem

With nightly-images-keon-2013-06-18.Gecko-42ecd5c.Gaia-adca6e9.zip I don't have the problem.
Keywords: regression
(Assignee)

Comment 3

5 years ago
Here is what I get using master:

I/Gecko   (  829): RIL Worker[0]: OPL: [2]: {"mcc":"302","mnc":"880","lacTacStart":0,"lacTacEnd":65534,"pnnRecordId":1}


mnc should be 220 I have to believe the apn.json

Note: at the moment I'm not even getting the network.
(Assignee)

Comment 4

5 years ago
But after rebooting again I get the network.

And the proper mnc.

(but that does not solve any problem at all, it just show there is something wrong)
(Assignee)

Comment 5

5 years ago
Adding geeksphone since the problem occur also with their images.
(Assignee)

Comment 6

5 years ago
If I dunmp what loadJSON return for the apn data, I get this:

E/GeckoConsole( 4009): Content JS LOG at app://settings.gaiamobile.org/js/carrier.js:82 in loadAPN: apn {"202":"Europe/Athens","204":"Europe/Amsterdam","206":"Europe/Brussels","208":"Europe/Paris","214":"Europe/Madrid","216":"Europe/Budapest","218":"Europe/Sarajevo","219":"Europe/Zagreb","220":"Europe/Belgrade","222":"Europe/Rome","226":"Europe/Bucharest","228":"Europe/Zurich","230":"Europe/Prague","231":"Europe/Bratislava","232":"Europe/Vienna","234":{"10":"Europe/London","11":"Europe/London","15":"Europe/London","20":"Europe/London","30":"Europe/London","31":"Europe/London","32":"Europe/London","33":"Europe/London","34":"Europe/London","36":"Europe/Isle_of_Man","50":"Europe/Jersey","55":"Europe/Jersey","58":"Europe/Isle_of_Man","00":"Europe/London","02":"Europe/London","03":"Europe/Jersey"},"238":"Europe/Copenhagen","240":"Europe/Stockholm","242":"Europe/Oslo","244":"Europe/Helsinki","246":"Europe/Vilnius","247":"Europe/Riga","248":"Europe/Tallinn","250":"Europe/Moscow","255":"Europe/Kiev","257":"Europe/Minsk","259":"Europe/Chis


Doesn't look good.

Time to bisect.
(Assignee)

Comment 7

5 years ago
This is not carrier specific

apn.json is packaged in the settings application.zip with the content of apn_tz.json. That's how we get that invalid data.
Summary: No APN settings for Koodo → No APN settings broken (for Koodo)
(Assignee)

Comment 8

5 years ago
Regression is at

commit 6e78863eeff44198e76fae6ef501f9cb073e194e
Merge: 16a5340 e8191ba
Author: Rex KM Lee <rexboy@mozilla.com>
Date:   Mon Jul 1 19:56:38 2013 -0700

    Merge pull request #10670 from rexboy7/fixhd-887742
    
    Fix bug 887742 - Let GAIA_DEV_PIXELS_PER_PX valid for files in resources/branding
(Assignee)

Comment 9

5 years ago
The real commit is actually  e8191ba03a24507303515c58a61532868306fa8e

apn_tz.json and apn.json are NOT the same thing and are not related to HD.
(Assignee)

Updated

5 years ago
Summary: No APN settings broken (for Koodo) → APN settings broken (for Koodo)
(Assignee)

Comment 10

5 years ago
request hd? because the regression was introduced by a hd+ bug.
blocking-b2g: --- → hd?
(Assignee)

Comment 11

5 years ago
Created attachment 773757 [details] [diff] [review]
Proposed patch

I tried to actually do a PR on github, but I got bitten by bug 892329
(Assignee)

Updated

5 years ago
Attachment #773757 - Attachment is patch: true
Thanks!

master: https://github.com/mozilla-b2g/gaia/commit/f04f45478e68ad7739e74b5613e2502d3f684888
v1.1.0hd: a2dbe6eb4a5d36f909698e64faa51535787dbc1a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.1hd: --- → fixed
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Whiteboard: [c= s=2013.07.12]

Updated

5 years ago
Assignee: nobody → hub
Mass-modify - removal of no longer relevant blocking flags.

Updated

4 years ago
blocking-b2g: hd? → ---
You need to log in before you can comment on or make changes to this bug.