Blank browser on OS X 10.7 and retina display, when full screen

RESOLVED FIXED in Firefox 23

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: milan, Assigned: milan)

Tracking

({regression})

unspecified
mozilla25
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ fixed, firefox24+ fixed, firefox25+ fixed)

Details

(Whiteboard: [qa-])

(Assignee)

Description

5 years ago
With bug 807096, we limited the texture size to 2k on 10.7 and less.  With the retina display, that means resizing the browser beyond about 70% of the width gets you above that limit and you don't see anything in your browser.
(Assignee)

Updated

5 years ago
Assignee: nobody → milan
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox25: --- → affected
Keywords: regression
I would suggest that we can't ship with this.
tracking-firefox23: --- → ?
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?
(That is, bug 807096 was backed out.)
https://hg.mozilla.org/mozilla-central/rev/e35388d6d558
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
status-firefox25: affected → fixed

Comment 5

5 years ago
Please nominate for uplift, we'll approve.
status-firefox22: --- → unaffected
tracking-firefox23: ? → +
tracking-firefox24: ? → +
tracking-firefox25: ? → +
(Assignee)

Comment 6

5 years ago
This will be fixed when bug 807096 is backed out, and those backouts have been approved in that bug. Is that sufficient, or should we nominate in here as well?
marking fixed on branches since the backout was done across all.
status-firefox23: affected → fixed
status-firefox24: affected → fixed
Matt, can you please verify this is fixed on your retina Mac?
Keywords: verifyme
QA Contact: mwobensmith
I have a Retina Mac with 10.8 only. Did this model even ship with 10.7?

It doesn't appear that I will be able to verify this bug with this config.
(In reply to Matt Wobensmith from comment #9)
> I have a Retina Mac with 10.8 only. Did this model even ship with 10.7?
> 
> It doesn't appear that I will be able to verify this bug with this config.

Fair point. I'll see if I can find someone else to verify this. In the meantime I'm tagging this [qa-].
Keywords: verifyme
Whiteboard: [qa-]
ashughes asked me to help verify this: verified on Mac 10.7 using:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:25.0) Gecko/20100101 Firefox/25.0

Verified using the site in the other bug, https://sketchfab.com/show/hZimZzGxleN5z9GgguH5DgvbQDl. I am able to see all content when resizing the window.

Side note: When resizing the window, the site above does not paint smoothly at all using Firefox, while on chrome it paints very smoothly.
You need to log in before you can comment on or make changes to this bug.