Closed Bug 891609 Opened 6 years ago Closed 6 years ago

[B2G][Leo][Bluetooth File Transfer] When sending a file via bluetooth an incorrect message is displayed: "Receiving Bluetooth transfer.."

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:leo+, firefox23 wontfix, firefox24 wontfix, firefox25 fixed, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE5
blocking-b2g leo+
Tracking Status
firefox23 --- wontfix
firefox24 --- wontfix
firefox25 --- fixed
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: jzimbrick, Assigned: ben.tian)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Description:
When a user is sending a file via bluetooth to another phone, the message "Receiving Bluetooth transfer.." is displayed over the progress bar in the dropdown menu.

Repro Steps:
1. Update Leo device to build 20130709070206.
2. Pair another device using bluetooth.
3. Send a file to the paired device. (Using a larger file like music or video makes seeing the next step easier.)
4. In the drop down menu, observe that "Receiving Bluetooth transfer.." is displayed instead of a message about sending a file.

Actual:
"Receiving Bluetooth transfer.." is displayed in the dropdown menu when sending a file over bluetooth.

Expected:
A message like "Sending Bluetooth transfer..." is displayed.

Environmental Variables:
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f917f3fb17ab
Gaia: e251ee6bdab13d8620afa8f9c2d5f14e5e6a4f99
Platform Version: 18.1
RIL Version: 01.01.00.019.152 

Notes:
Repro frequency: 100%
Q Analysts Team Priority: Pri 3
Not seeing this today on the latest Leo build from the commercial 1.1 branch:

Environmental  Variables:
Build ID: 20130710070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/5b34e0cda635
Gaia: 61453c4d32beb15a33ec91b2e740e96e5ce45759
Platform Version: 18.1
RIL Version: 01.01.00.019.157

There's now a message correctly stating that a file is being sent.

Resolving as works for me.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
And nevermind, back the next day. This issue was not occurring during the previous day's smoketest.

Seeing this issue again on the latest Leo build from the commercial 1.1 branch:

Environmental  Variables:
Build ID: 20130711070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/aaa74e5efaf1
Gaia: 7cdcc46179d198cab11970964b181ede32a5b683
Platform Version: 18.1
RIL Version: 01.01.00.019.158

Re-opening issue.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Steps to reproduce with Gaia device and second Bluetooth device:
1. Send from second BT device a file to the Gaia one.
2. Accept the file transfer on Gaia.
3. Send a video from the Gaia device to the second BT device. While the accept prompt on the second BT device is shown, press the Home button on the Gaia device and drag down the notifcations view. "Receiving Bluetooth transfer" is shown. (Like in step 1).

Further information:
Sending the video again will show the correct title "Sending Bluetooth transfer"
The bug cause is that bluetooth opp manager sets mIsServer=false AFTER broadcasting system message to gaia, so gaia receives the value of last transfer and shows incorrect dialog sometimes.

The patch sets mIsServer=false before notifying gaia to fix the bug. This fix is v1-train only as it's already landed on master by bug 891202.
Assignee: nobody → btian
Attachment #782449 - Flags: review?(echou)
Set leo? to fix the v1-train only bug.
blocking-b2g: --- → leo?
Triage - leo+ agreed.
blocking-b2g: leo? → leo+
Comment on attachment 782449 [details] [diff] [review]
Patch 1: [v1-train only] set correct mIsServer value before notifying gaia

Review of attachment 782449 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #782449 - Flags: review?(echou) → review+
* Update the patch for Ben
Attachment #782449 - Attachment is obsolete: true
Can we please go ahead and land if this is ready or are we waiting on anything here?
Whiteboard: [checkin-needed]
Wayne,

To be sure, the fix will be sync'd to hd branch after being landed to b2g18 branch right? Or I need to request hd+ flag additionally?
https://hg.mozilla.org/releases/mozilla-b2g18/rev/5317a86d17a2

This will land on v1.1hd automatically next time I merge b2g18 over. You don't need to do anything else.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed]
Target Milestone: --- → 1.1 QE5
Issue do not reproduces on Leo.
Build ID: 20130805071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 45f6a739b09292e16717fb21003386c914ca29c2
 When sending a file via Bluetooth received correct message is displayed: "Receiving Bluetooth transfer.."
Wile Sending showed "Sending Bluetooth transfer..." is displayed.
Apparently I forgot to mark this bug when it landed on the v1.1hd branch. My apologies.
https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/5317a86d17a2
Duplicate of this bug: 901405
You need to log in before you can comment on or make changes to this bug.