Single-signon can't observe profile change if no instances exist

VERIFIED FIXED in mozilla0.9.3

Status

P1
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: ccarlen, Assigned: ccarlen)

Tracking

Trunk
mozilla0.9.3

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+)

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
This was going to be checked in with bug 86021 but that's no longer going into
the branch. This needs to for the sake of embedding clients using profile
switching. The problem is this: nsISingleSignon observes profile changes. Since
these are components and not a service, if the last instance is destroyed before
switching the profile (typical) there's nothing to observe the change and signon
data is not flushed. I'm not sure why this was never noticed before. Maybe we
were leaking a signon.

Comment 1

17 years ago
we should use app-startup components to instantiate a profile change listener...
(Assignee)

Comment 2

17 years ago
Created attachment 41134 [details] [diff] [review]
patch to make the observer static
(Assignee)

Comment 3

17 years ago
Alec, this is the same patch that you sr'd before with changes from your
comments. The static member var is no longer an nsIObserver* but a simple
PR_Bool and it's commented a bit better. Can you sr= this one? Steve, can you r=?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 4

17 years ago
Alec, I didn't see your comment before posting that patch.
> we should use app-startup components
I like that idea. On the other hand, this patch is tested and ready.

Comment 5

17 years ago
works for me!
sr=alecf

Comment 6

17 years ago
Sorry, Steve's on vacation this week.  But I approve your making this change to 
the wallet module.  But you'll need to get someone else to do the review if you 
want it done this week.
(Assignee)

Updated

17 years ago
Priority: -- → P1

Comment 7

17 years ago
r=valeski

Updated

17 years ago
Keywords: nsBranch

Comment 8

17 years ago
let's get this into the branch and trunk.
Whiteboard: PDT+
(Assignee)

Comment 9

17 years ago
Fix checked into branch & trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Verified fix checked into lxr.mozilla.org
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.