Help is blank on first launch

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: rudman, Assigned: oeschger)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Moving info from Bugscape 6995. Note that Mozilla builds will say "Help
Contents," not Help and Support Center.

Observed on 07-03-06-0.9.2 build on Win98.

Steps:

1) Launch Mail.
2) Click Help menu.  Top entry should say "Help and Support Center", but it is
blank (it does appear in browser Help menu though).  Clicking on the blank entry
does open the Help Center window (which is also blank--see my comment in Bug 6872).



------- Additional Comments From Jon Rubin 2001-07-03 17:26 -------

Created an attachment (id=2085)
Screenshot



------- Additional Comments From Jon Rubin 2001-07-03 17:58 -------

Note: I observed this problem after doing an update to the 6.1b (06-07-13-0.9.1)
build.  If I do a new install, this problem does not occur.



------- Additional Comments From Jon Rubin 2001-07-03 18:11 -------

Filed bug 6998, which also resulted after updating build instead of installing
from scratch.



------- Additional Comments From rudman@netscape.com 2001-07-03 18:40 -------

-->reassigning to Ian, cc'ing Bhuvan.

Probably a dupe of 6998.
(Assignee)

Comment 1

17 years ago
Responding identically to these two bugs (this and 6998, commercial side):

Sorry to be so dense, but what does "update build" mean? 

As recently as last week, we had some fallout from the localization of all the 
help content (including the strings for the UI, whose absense would result in a 
help viewer a lot like that screenshot), but I checked in the fixes and saw it, 
as far as I knew, resolved.
Status: NEW → ASSIGNED
(Reporter)

Comment 2

17 years ago
Ian, when Bhuvan attempted to open the Help using a Moz debug build, and he
viewed the console, there was an error that appeared to be some docshell thingy.
I'm not sure who might help here, but I think that changes that went into the
builds overnight are causing the havoc. Maybe check with saari?
(Assignee)

Comment 3

17 years ago
cc'ing saari per rudman's suggestion.
Can someone post the error here? thanks.

Comment 4

17 years ago
Ian, "update" in this case means that I ran update.html instead of installing
using N6Setup.exe.  It's in the same folder as N6Setup.exe.

Comment 5

17 years ago
Clicking Help in one of the Prefs Panels leads to the same problem.

Comment 6

17 years ago
Created attachment 41143 [details]
console dump which has js error, a possible cause for all this
(Reporter)

Comment 7

17 years ago
Will there be SmartUpdate for NS 6.1? I thought the decision was there wouldn't
be. So update.html may be irrelevant (or confusing the issue here).

Comment 8

17 years ago
From what I noticed :

* Branch builds are good. Displays help contents (toc & content) properly. 
Tested with the latest branch build avialable.

* Trunk builds are affected, and looks like the regression has been introduced 
after we branched.

On trunk the cases, I see this problem in the following circumstances 
only. 
 -- when I started mozilla -mail -p foo
 -- or mozilla -editor -p foo

Starting browser using -p option (and then launching editor/mailnews from there) 
will bring up help window properly.

So, the major concern here is that when we launch mailnews via Windows Start 
Button->Programs->Netscape 6->mail (and then select a profile if needed) and the 
equivalent on other platforms, exhibits the problem reported i.e., displaying 
the blank content frame in the help window on first launch. Adding mailtrack 
keyword.


Keywords: mailtrack
(Assignee)

Comment 9

17 years ago
When I think webNavigation, I think jag. cc'ing him here for some insight. 

Jag, looks like some kind of regression on the trunk--perhaps a change to the 
webNavigation interface?--has resulted in some bustage for the help window. Any 
insight here? Thanks. 

Comment 10

17 years ago
None that I know of.
(Assignee)

Comment 11

17 years ago
Marking FIXED. This was temporary weirdness coming from the move from help.jar
-> en.jar, I think. Gone now, at any rate.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.