[Seville] Purchase not installed and not being able to do any more purchases

RESOLVED WORKSFORME

Status

P1
blocker
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: erjica, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/536.30.1 (KHTML, like Gecko) Version/6.0.5 Safari/536.30.1

Steps to reproduce:

Don't have much details since this comes from certification.

1) Do a purchase with Carrier Billing
2) Payment is confirmed


Actual results:

- The install button triggers "Install failed, try again after some minutes"
- Any further attempts to purchase apps freeze in "Please, wait…"


Expected results:

- App gets installed
- Further payments work
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Priority: -- → P1
(Reporter)

Comment 1

5 years ago
Bumping priority. This blocked concluding certification yesterday.
(Reporter)

Comment 2

5 years ago
If they cannot re-test today successfully, this would impact our current timelines.
Keir are you seeing any issues your end that might point to this?
Flags: needinfo?(keir)

Comment 4

5 years ago
I think we need more information on this issue to be able to start tracking things down:

- which app is being purchased
- screenshots of error messages for example "Install failed, try again after some minutes" isn't a string I'm familiar with and "Please, wait…" is a screen where
- presuming this is on mozilla production, with a SIM card in Spain
- on wifi or 3g?

Once we've got more info, we'll be able to move forward.
Flags: needinfo?(keir)
Can we also get a logcat so we can check the JavaScript/platform error that is causing the install failure?
(Reporter)

Comment 6

5 years ago
Andy, Kumar, info that's aready known:

- It's Seville, not Moss
- Seville has been in QA and certification in Stage
- The error seems to be this one: https://bug882740.bugzilla.mozilla.org/attachment.cgi?id=772660
- Wifi or 3G should be the same in Seville since there's no difference in the purchase flow (no network authentication)


They tried today again purchasing Aplicación Test App(test 8) $2.060 and Broardbaspled Bipostred $6.240 and purchase process doesn't seem to be triggered.

We asked for more details, but we won't be able to get logs or a lot of detail since this is on the certification checks.
can we get the names of the exact apps they are trying? the 'install failed' could be many different things, could be network related, could be a malformed manifest, etc.
I'll see if we can reproduce it given the app names you listed, thanks

Comment 9

5 years ago
(In reply to Ernesto Jimenez from comment #6)
> Andy, Kumar, info that's aready known:
> 
> - It's Seville, not Moss
> - Seville has been in QA and certification in Stage
> - The error seems to be this one:
> https://bug882740.bugzilla.mozilla.org/attachment.cgi?id=772660
> - Wifi or 3G should be the same in Seville since there's no difference in
> the purchase flow (no network authentication)
> 
> 
> They tried today again purchasing Aplicación Test App(test 8) $2.060 and
> Broardbaspled Bipostred $6.240 and purchase process doesn't seem to be
> triggered.
> 
> We asked for more details, but we won't be able to get logs or a lot of
> detail since this is on the certification checks.

If there are testing on Stage and not able to install the app- "Broardbaspled Bipostred" that is a known issue since that is a packaged app and you need certs to install packaged apps.

Comment 10

5 years ago
> If there are testing on Stage and not able to install the app-
> "Broardbaspled Bipostred" that is a known issue since that is a packaged app
> and you need certs to install packaged apps.

correction: "If they" not "if there" :)
Ernesto, can you ask if they can reproduce this on a non-packaged app? Searching :paid :packaged shows packaged; searching :paid and comparing to that list will let them find non-packaged. Indeed, it sounds like the install failure was due to lack of stage certs (blocked by bug 877531)
(Reporter)

Comment 12

5 years ago
Kumar, Steve told me Felipe went to the operator's offices to support them and help you track the issue.

He should be in a better place to get the details.

Comment 13

5 years ago
The sample was re-flashed on 7/10/2013 and the error did not happen again.
Also, we performed extra tests with several other apps, with correct results.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.