Phonebook :: Edit Your Profile :: Unclear error alert

VERIFIED FIXED in 2013-07-25

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sandeep.b, Unassigned)

Tracking

other
2013-07-25
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22

Steps to reproduce:

1.Signed into Phonebook as a non vouched user.
2.Clicked on "Edit Your Profile" from the drop down toggle.
3.Left the Full Name field blank and clicked on Update. 


Actual results:

Got an error alert "Please correct the following errors: 1.full_name"

The input id and field name is 'full_name' in HTML source.


Expected results:

Showing the label what is shown on screen, is more meaningful. On screen it reads 'Full Name'.  Text showing as 'below will be helpful.

Please correct the following errors:

1. Enter the Full Name.
(Reporter)

Comment 1

6 years ago
Created attachment 773239 [details]
Screenshot showing Error alert
Whiteboard: [kb=1044317]
The appropriate error message is specified in https://bugzilla.mozilla.org/show_bug.cgi?id=797790#c6:

1. Change the error message string to:
"Please complete the following field" (if there are multiple error messages, let's say "fields")

The current error message string says:
"The following fields are required (optin is the checkbox in the last panel):"

2. Change the wording when a required field is missing:
* "Full Name" [currently says 'full_name']
Duplicate of this bug: 845801
Target Milestone: --- → 2013-07-25
Clarification:

The spec in comment 2 should apply to all error messages presented by the register/edit form. I believe there are 3:

* country
* full name
* (on register) privacy policy opt-in (covered separately by https://bugzilla.mozilla.org/show_bug.cgi?id=891841)

When this bug is fixed, form validation errors will be presented in a uniform way and will use non-slug strings to explain what's going on. Aside from field names, the rest of the strings are specified in comment 2.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Assignee: nobody → julia
There's a 4th error condition: Full name is blank. Bug for that one: https://bugzilla.mozilla.org/show_bug.cgi?id=766702

Comment 6

6 years ago
After spending some time evaluating this bug, and getting sign-off from Sancus, it seems that the form needs to be re-worked a bit in order to get the correct values for the error messages.
Assignee: julia → nobody
:sancus, :giorgos, would one of you be up for modifying the form so its error messages do not print slugs? Spec in comment 2, clarification in comment 3, addendum in comment 4.
Flags: needinfo?
I vote for displaying a generic error message like "Please correct the following errors" and we display errors bellow each field with error. We can also highlight the field.

This display fits better the new design since the page is now pretty long and the user should scroll top-down to find the missing fields.

In any case, yes we can fix the error messages.
Flags: needinfo?
I like the approach Giorgos suggests in comment 8. Can the errors below each field be custom? Examples:

"Full name is required."
"Country is required."
"You must accept Mozilla's <link>privacy policy</link> to join Mozillians."
"Username cannot be blank."
Whiteboard: [kb=1044317]
(In reply to Justin Crawford [:hoosteeno] from comment #9)
> I like the approach Giorgos suggests in comment 8. Can the errors below each
> field be custom? Examples:
> 
> "Full name is required."
> "Country is required."
> "You must accept Mozilla's <link>privacy policy</link> to join Mozillians."
> "Username cannot be blank."

Those custom messages look good to me. I think that covers all of the required fields.
As part of bug 895459 we created a generic error message at the top of the form and inline with the fields causing the error. It's live in dev: https://mozillians-dev.allizom.org/en-US/user/edit/
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
QA verified on stage - Sandeep thank you for bringing this bug to our attention. The latest user profile edit design/workflows are live on stage and ready for you to explore - mozillians.allizom.org - have fun and enjoy.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.