Closed Bug 891889 Opened 8 years ago Closed 8 years ago

Only running 2 of 3 chunks for Android 4.0 robocop

Categories

(Release Engineering :: General, defect)

x86
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gbrown, Assigned: Callek)

References

Details

Attachments

(1 file)

Regression from bug 829211?

build/ mozharness/ configs/ android/ android_panda_releng.py has:

     "all_robocop_suites": {
         #plain is split
         "robocop-1": ["--total-chunks=3", "--this-chunk=1"],
         "robocop-2": ["--total-chunks=3", "--this-chunk=2"],
     },

tegras (android 2.2) have --total-chunks=2
Assignee: nobody → bugspam.Callek
Blocks: 829211
found in triage.
Component: Release Engineering: Platform Support → Release Engineering: Automation (General)
QA Contact: coop → catlee
Adding the qa-automation-blocked whiteboard tag so the issue can be tracked since it blocks the integration of new Robocop tests
Whiteboard: [qa-automation-blocked]
So this fixes the regression (typo afaict)

Prior to mozharness unittests this was 2 chunks in configs, and we're still scheduling only 2 robocop hunks.

There is risk of causing orange due to the missing tests this will re-add to active jobs, if there is a strong feeling there we can write a different patch to make it 3 chunks, I'm in favor of this patch out of our choices though.
Attachment #776623 - Flags: review?(armenzg)
Attachment #776623 - Flags: feedback?(gbrown)
Comment on attachment 776623 [details] [diff] [review]
[mozharness] simple patch

Review of attachment 776623 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #776623 - Flags: review?(armenzg) → review+
Comment on attachment 776623 [details] [diff] [review]
[mozharness] simple patch

 https://hg.mozilla.org/build/mozharness/rev/6ad3e079a31b

This should be live on cedar as of now, pending mozharness merge to production for other trees
Attachment #776623 - Flags: feedback?(gbrown) → checked-in+
Verified live and working great on m-c, m-i, and try - thanks!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa-automation-blocked]
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.