Intermittent test_bug594730.html, test_hc_attrnextsiblingnull.html, test_secondPlugin.html, test_bug593174.html, test_pluginstream_err.html, test_bug73586.html, browser_webconsole_network_panel.js | application crashed [@ GetContextFromObjectOrDefault]

RESOLVED WONTFIX

Status

()

P5
normal
RESOLVED WONTFIX
5 years ago
19 days ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [leave open], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=25094632&tree=Mozilla-Inbound

Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitest-5 on 2013-07-09 17:10:05 PDT for push a65599fc1dd4
slave: talos-r4-lion-086

17:15:04     INFO -  169603 INFO TEST-START | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html
17:15:04     INFO -  169604 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169605 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169606 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169607 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169608 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169609 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169610 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169611 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should have matched the Unicode escape.
17:15:04     INFO -  169612 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should not have matched the Unicode escape.
17:15:04     INFO -  169613 INFO TEST-END | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | finished in 179ms
17:15:06  WARNING -  TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Exited with code 1 during test run
17:15:06     INFO -  INFO | automation.py | Application ran for: 0:03:18.155683
17:15:06     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmp4G9_nipidlog
17:15:06     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1373408158/firefox-25.0a1.en-US.mac.crashreporter-symbols.zip
17:15:06     INFO -  Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1373408158/firefox-25.0a1.en-US.mac.crashreporter-symbols.zip
17:15:38  WARNING -  PROCESS-CRASH | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | application crashed [@ GetContextFromObjectOrDefault]
17:15:38     INFO -  Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpBg62Eo/minidumps/6D2DCFB2-C709-42B6-B748-D458F1C5E1B2.dmp
17:15:38     INFO -  Operating system: Mac OS X
17:15:38     INFO -                    10.7.2 11C74
17:15:38     INFO -  CPU: amd64
17:15:38     INFO -       family 6 model 23 stepping 10
17:15:38     INFO -       2 CPUs
17:15:38     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
17:15:38     INFO -  Crash address: 0x0
17:15:38     INFO -  Thread 17 (crashed)
17:15:38     INFO -   0  XUL!GetContextFromObjectOrDefault [xpcprivate.h:a65599fc1dd4 : 458 + 0x0]
17:15:38     INFO -      rbx = 0x000000010f609aa0   r12 = 0x00000001177feb80
17:15:38     INFO -      r13 = 0x00000001031e1ffc   r14 = 0x00000001177feb80
17:15:38     INFO -      r15 = 0x00007fff74ebdf60   rip = 0x00000001023ad8e7
17:15:38     INFO -      rsp = 0x000000010f609800   rbp = 0x000000010f609910
17:15:38     INFO -      Found by: given as instruction pointer in context
17:15:38     INFO -   1  XUL!nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**) [XPCWrappedJSClass.cpp:a65599fc1dd4 : 624 + 0x7]
17:15:38     INFO -      rbx = 0x000000010f609aa0   r12 = 0x00000001177feb80
17:15:38     INFO -      r13 = 0x00000001031e1ffc   r14 = 0x000000010f609ae8
17:15:38     INFO -      r15 = 0x000000010f609aa0   rip = 0x00000001023ad3c1
17:15:38     INFO -      rsp = 0x000000010f609920   rbp = 0x000000010f609a70
17:15:38     INFO -      Found by: call frame info
17:15:38     INFO -   2  XUL!nsQueryReferent::operator()(nsID const&, void**) const [nsWeakReference.cpp:a65599fc1dd4 : 56 + 0x8]
17:15:38     INFO -      rbx = 0x000000010f609aa0   r12 = 0x00000001177f2400
17:15:38     INFO -      r13 = 0x0000000000000001   r14 = 0x000000010f609ae8
17:15:38     INFO -      r15 = 0x0000000103df33f0   rip = 0x0000000101659fc4
17:15:38     INFO -      rsp = 0x000000010f609a80   rbp = 0x000000010f609a90
17:15:38     INFO -      Found by: call frame info
17:15:38     INFO -   3  XUL!nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&) [nsCOMPtr.cpp:a65599fc1dd4 : 110 + 0x11]
17:15:38     INFO -      rbx = 0x000000010f609b00   r12 = 0x00000001177f2400
17:15:38     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000001
17:15:38     INFO -      r15 = 0x0000000103df33f0   rip = 0x000000010165679b
17:15:38     INFO -      rsp = 0x000000010f609aa0   rbp = 0x000000010f609ab0
17:15:38     INFO -      Found by: call frame info
17:15:38     INFO -   4  XUL!nsDocLoader::DoFireOnStateChange(nsIWebProgress*, nsIRequest*, int&, tag_nsresult) [nsCOMPtr.h:a65599fc1dd4 : 747 + 0xb]
17:15:38     INFO -      rbx = 0x0000000100370048   r12 = 0x00000001177f2400
17:15:38     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000001
17:15:38     INFO -      r15 = 0x0000000103df33f0   rip = 0x0000000102414e77
17:15:38     INFO -      rsp = 0x000000010f609ac0   rbp = 0x000000010f609b30
17:15:38     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

5 years ago
Blocks: 895024
(Reporter)

Comment 3

5 years ago
Bobby, we're seeing this and bug 895024 intermittently. Any chance you could take a look if you get a chance?
Flags: needinfo?(bobbyholley+bmo)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Whoa, this is bad - for some reason, thread 17 is touching XPCWrappedJS stuff, which is verboten (and causes XPConnect to abort).

It would be very helpful to know what XPCWrappedJS this is. How do I go about getting my hands on that minidump?
Flags: needinfo?(bobbyholley+bmo) → needinfo?(ryanvm)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 9

5 years ago
(In reply to Bobby Holley (:bholley) from comment #7)
> Whoa, this is bad - for some reason, thread 17 is touching XPCWrappedJS
> stuff, which is verboten (and causes XPConnect to abort).
> 
> It would be very helpful to know what XPCWrappedJS this is. How do I go
> about getting my hands on that minidump?

You can ping #releng to can get it for you (though they don't stick around on the slave forever, so you'll want to do so reasonably soon after it happens).
Flags: needinfo?(ryanvm)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Crash Signature: [@ GetContextFromObjectOrDefault]

Updated

5 years ago
Depends on: 904474
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Ok, looks like we just hit this. Callek, can you grab me the minidump from comment 12?
Flags: needinfo?(bugspam.Callek)
wow this dissapeared fast:

[cltbld@talos-r4-lion-012.build.scl1.mozilla.com ~]$ ls /var/folders/s5/b_ptq5b51zv6wvdzs2g4jg7400000w/T/tmpEr8Gok/minidumps/9CA64D0A-79CE-4B97-A90D-F0273784779D.dmp
ls: /var/folders/s5/b_ptq5b51zv6wvdzs2g4jg7400000w/T/tmpEr8Gok/minidumps/9CA64D0A-79CE-4B97-A90D-F0273784779D.dmp
: No such file or directory
[cltbld@talos-r4-lion-012.build.scl1.mozilla.com ~]$ ls /var/folders/s5/b_ptq5b51zv6wvdzs2g4jg7400000w/T/tmpEr8Gok/minidumps
ls: /var/folders/s5/b_ptq5b51zv6wvdzs2g4jg7400000w/T/tmpEr8Gok/minidumps: No such file or directory
[cltbld@talos-r4-lion-012.build.scl1.mozilla.com ~]$ Connection to talos-r4-lion-012.build.mozilla.org closed by remote host.
Connection to talos-r4-lion-012.build.mozilla.org closed.
Flags: needinfo?(bugspam.Callek)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Summary: Intermittent test_bug594730.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault] → Intermittent test_bug594730.html, test_hc_attrnextsiblingnull.html | application crashed [@ GetContextFromObjectOrDefault]
Comment hidden (Treeherder Robot)
Hey Callek, can I get a minidump?
Flags: needinfo?(bugspam.Callek)
(In reply to Bobby Holley (:bholley) from comment #17)
> Hey Callek, can I get a minidump?

http://people.mozilla.org/~jwood/tmp/1C7214B6-7F15-4453-BF98-719FC8C61A87.dmp
Flags: needinfo?(bugspam.Callek)
Comment hidden (Treeherder Robot)
(In reply to Justin Wood (:Callek) from comment #18)
> (In reply to Bobby Holley (:bholley) from comment #17)
> > Hey Callek, can I get a minidump?
> 
> http://people.mozilla.org/~jwood/tmp/1C7214B6-7F15-4453-BF98-719FC8C61A87.dmp

403 forbidden.
Flags: needinfo?(bugspam.Callek)
(In reply to Bobby Holley (:bholley) from comment #20)
> (In reply to Justin Wood (:Callek) from comment #18)
> > (In reply to Bobby Holley (:bholley) from comment #17)
> > > Hey Callek, can I get a minidump?
> > 
> > http://people.mozilla.org/~jwood/tmp/1C7214B6-7F15-4453-BF98-719FC8C61A87.dmp
> 
> 403 forbidden.

sorry people's default umask bit me again. should be fixed
Flags: needinfo?(bugspam.Callek)
Comment hidden (Treeherder Robot)
Created attachment 793321 [details] [diff] [review]
Print diagnostics when an XPCWrappedJS is QI-ed off-main-thread. v1

Let's try to figure out which XPCWrappedJS is causing this. I've filed a reminder
for myself to back this out by sept 3.
Attachment #793321 - Flags: review?(mrbkap)
From what I can glean from googling, I can't actually do anything with a mac minidump other than get the stack (which is already in the logs). Ted, can you confirm that this is correct? Assuming so, I'll land the diagnostic patch in comment 23.
Flags: needinfo?(ted)

Updated

5 years ago
Summary: Intermittent test_bug594730.html, test_hc_attrnextsiblingnull.html | application crashed [@ GetContextFromObjectOrDefault] → Intermittent test_bug594730.html, test_hc_attrnextsiblingnull.html, test_secondPlugin.html, test_bug593174.html, test_pluginstream_err.html, test_bug73586.html, browser_webconsole_network_panel.js | application crashed [@ GetContextFromObjectOrDefault]

Updated

5 years ago
No longer blocks: 895024
Duplicate of this bug: 895024
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Correct, there are no tools to do anything more useful with a minidump on Mac than get the stack out.

(Also, vaguely related, RelEng is on track to fix bug 642167 in the near future so that minidumps from test slaves will be simple to get.)
Flags: needinfo?(ted)
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #29)
> Correct, there are no tools to do anything more useful with a minidump on
> Mac than get the stack out.
> 
> (Also, vaguely related, RelEng is on track to fix bug 642167 in the near
> future so that minidumps from test slaves will be simple to get.)

Ok. Waiting on Blake's review for the diagnostic patch then.
Comment on attachment 793321 [details] [diff] [review]
Print diagnostics when an XPCWrappedJS is QI-ed off-main-thread. v1

Review of attachment 793321 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/xpconnect/src/XPCWrappedJSClass.cpp
@@ +573,5 @@
>                                               void** aInstancePtr)
>  {
> +    if (MOZ_UNLIKELY(!NS_IsMainThread())) {
> +        printf("Uh oh! DelegatedQueryInterface called off-main-thread!\n");
> +        printf("Name: %s\n", GetInterfaceName());

Is it worth printing the IID as well?

@@ +584,5 @@
> +        } else {
> +            printf("Unable to get origin from principal :-(\n");
> +        }
> +        nsAutoCString loc(EnsureCompartmentPrivate(c)->GetLocation());
> +        printf("Global's Location: %s\n", loc.get());

I don't think you actually need the explicit local autostring here, right?
Attachment #793321 - Flags: review?(mrbkap) → review+
(In reply to Blake Kaplan (:mrbkap) from comment #31)
> Comment on attachment 793321 [details] [diff] [review]

> Is it worth printing the IID as well?

I'm not sure what information that would give us on top of the interface name, and I don't know how to format an IID for printing offhand.

> > +        nsAutoCString loc(EnsureCompartmentPrivate(c)->GetLocation());
> > +        printf("Global's Location: %s\n", loc.get());
> 
> I don't think you actually need the explicit local autostring here, right?

GetLocation returns an nsACString, which isn't null-terminated, so it doesn't have a get. So I can't pass it to printf, though maybe there's some other way.
Comment hidden (Treeherder Robot)
The diagnostics morphed the crash into bug 909613, which in turn pointed us to bug 904474. The diagnostics have served their purpose, so I've backed them out:

https://hg.mozilla.org/integration/mozilla-inbound/rev/7f683b01fb4f
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 41

2 years ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Priority: P3 → P5
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 19 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.