cannot retreive mail from yahoo.com pop3 server

VERIFIED INVALID

Status

MailNews Core
Networking: POP
VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: Paul Hammant, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

the mail retrieval remains stuck at 1 of xxx.  <Stop> still works and Mozilla
functions normally.

Reproducible: Always
Steps to Reproduce:
1. get yahoo.com account
2. configure pop retrival in mozilla
3. get mail

Actual Results:  mozilla hangs (recoverable)

Expected Results:  got my mail
(Assignee)

Comment 1

17 years ago
Could you help us in reproducing the problem by sending that message to this 
address test69360@yahoo.com, thanks

Comment 2

17 years ago
I would bet money this is bug 69360 and bug 83740 again.

When the patch to 69360 got checked in it fixed the problem in some cases but
not others.  I wish 69360 could be re-opened but that probably won't happen.

I believe this problem is related to Microsoft's POP3 server which runs yahoo's
mail and NYC Roadrunner which both have the symptom.  Clearly the server is
buggy (sending \0 which is banned by the RFC), but Moz should be robust enough
to handle such a popular server even if broken.

Naving, although I haven't been able to reproduce this from with email I
generate myself I would suggest that you subscribe some Mozilla test email
accounts and some Yahoo email accounts to the EFF newsletter
http://www.eff.org/effector/ because about half of their bimonthly newsletters
seem to manifest this problem.

Paul, when this happened to me the only work around was to use another program
to download the mail from yahoo.  Once the trouble message was gone Mozilla
could get the rest of the messages.
(Assignee)

Comment 3

17 years ago
ok, i will subscribe to the newsletter. 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
More info : my yahoo account is my second in mozilla.  The first (btinternet)
works fine - though slowly - thanks BT!

I can view the email through the webmail, abd it all fine.  I can even delete
oldest messages to see if that fixes things.  It does not.

I can wait for the bug to be fixed (esnible's suggestion), as I can see it all
through webmail.

Comment 5

17 years ago
Paul if you have had "leave messages on server" option checked then the oldest
messages may not be the ones causing the problem.  For example, if your mailbox
has twenty messages and Mozilla downloaded 10 of them, then the next time
through Mozilla will say "downloading 1 of 10" when it is actually downloading
11 of 20.

Try following the instructions
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap(Use POP3
instead of IMAP).  That option will capture the text of the problem message into
a file which you could delete through the web interface.

(This all assumes you are having the same problem I had, which we haven't
established.)
(Assignee)

Comment 6

17 years ago
I have not yet received any news letter from http://www.eff.org/effector/
Do I have to wait longer ?

Comment 7

17 years ago
Navin, an EFF newletter arrived today.  Mozilla 0.91 could not receive this
newsletter via POP3 from my RoadRunner ISP (Microsoft POP3 server).

(I forgot to test this with the daily build, sorry.)
(Assignee)

Comment 8

17 years ago
Created attachment 42581 [details]
the newsletter I just received.
(Assignee)

Comment 9

17 years ago
I am using the latest trunk build. buildid : 071604

Comment 10

17 years ago
Navin-
Sorry this is being difficult to reproduce.  I manifested the problem twice
today using build 2001071808/Linux.  Both cases were emails generated by a
Hotmail user.  I was able to duplicate the problems SMTPing the messages to my
own account.  I sent one of them to 3qatest03 as well.  Yahoo Mail is acting
weird but when it comes online again I'll try to create an account there which
holds the problem message for further testing.

Comment 11

17 years ago
Naving, have you been able to reproduce this with the yahoo.com account you
created and subscribed to the EFF list?  My Roadrunner address is getting a ton
of mail from the EFF about the Russian programmer arrest and Moz can't download
any of it.
(Assignee)

Comment 12

17 years ago
Ok, I just downloaded 4 mails in this account. They are about the russian
programmer arrest and with subject "EFFector 14.15: Uproar Around the World over 
Sklayrov Arrest; More!". I am using the latest trunk build, but nothing 
has changed in this code since I fixed 69360. I am not sure why you are
unable to download these mails. 
(Assignee)

Comment 13

17 years ago
and it works on both linux and win32. 
(Reporter)

Comment 14

17 years ago
It is still a bug for me with Mozilla 0.9.3.  Again it is difficult to tell
which particular email is the first that yahoo.com's mailserver is feeding to
mozilla and cause the thing to get stuck.

I am going to try Yahoo's helphdesk to see if they might be able to isolate the
email for Mozilla people.
(Assignee)

Comment 15

17 years ago
Do you get an error msg something like "Unable to write the email to the 
mailbox. Make sure the file system allows you write privileges, and you have 
enough disk space to copy the mailbox." when you are unable to download the 
message. 
(Reporter)

Comment 16

17 years ago
*** Not a Bug after all ***

1) Plenty of disk space
2) No error message, just hang
3) Affected Outl**k express too <spit>, but it downloaded in reverse order so
when it hung it was at the end rather than the beginning of a 927 item d/l.
4) I then went on to manually delete email in online yahoo, then imported the
mail from Outlook Express (excuse my continued cursing) into Mozilla.
5) Now when I get mail in Mozilla from mail.yahoo.com, it all works fine.
6) It was a single problematic email that's now deleted.
7) Sorry for wasting time of persons fighting the good fight.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 17

17 years ago
verified invalid.  
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.