If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text/label for canceling mouse pointer lock doorhanger with ESC key doesn't linewrap, gets cropped, but popup is bigger

RESOLVED FIXED in Firefox 36

Status

()

Firefox
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: aryx, Assigned: Gijs)

Tracking

Trunk
Firefox 36
Points:
1
Bug Flags:
firefox-backlog +
in-testsuite -
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Created attachment 773564 [details]
screenshot of issue

Tested on latest Firefox Nightly and Beta, with Windows XP SP3 32 bit

In some localized builds (e.g. German), the label for canceling the point lock with the ESC key doesn't fit into one line, but it doesn't get line-wrapped - it get's cropped. But the popup is wider than normal, see screenshot.

Test page:
http://mozilla.pettay.fi/moztests/pointerlock.html
Duplicate of this bug: 1085349
Summary: Text/label for canceling pointer lock doorhanger with ESC key doesn't linewrap, gets cropped, but popup is bigger → Text/label for canceling mouse pointer lock doorhanger with ESC key doesn't linewrap, gets cropped, but popup is bigger
Duplicate of this bug: 1085324
The popup was added in bug Bug 737100
Blocks: 737100
Flags: needinfo?(bugs)

Comment 4

3 years ago
That popup is coming from FF UI.
Perhaps Tim knows something about it.
Flags: needinfo?(bugs) → needinfo?(ttaubert)
Looks like some CSS issue that shouldn't be hard to fix. I wonder if that affects other languages or popups. Putting in the Firefox backlog so that we can prioritize it.
Flags: needinfo?(ttaubert) → firefox-backlog+
Based on this, it affects a ton of languages
http://transvision.mozfr.org/string/?entity=browser/chrome/browser/browser.dtd:pointerLock.notification.message&repo=aurora
(Assignee)

Comment 7

3 years ago
Created attachment 8512273 [details] [diff] [review]
fix pointerlock label to wrap,

Ran into this via the dupe because I watch untriaged. We just need to make the label the kid of the <label> element instead of putting it in the value attribute. Tested on OS X with an extra-long label, this seems to work.
Attachment #8512273 - Flags: review?(ttaubert)
(Assignee)

Updated

3 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
(Assignee)

Comment 8

3 years ago
Marco, can you add this (see comment #7) to next iteration, considering it's late on Monday? :-)
Iteration: --- → 36.2
Points: --- → 1
Flags: qe-verify-
Flags: needinfo?(mmucci)
Flags: in-testsuite-

Updated

3 years ago
Flags: needinfo?(mmucci)
Attachment #8512273 - Flags: review?(ttaubert) → review+
(Assignee)

Comment 9

3 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/dcfb1ac1935c
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/dcfb1ac1935c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
You need to log in before you can comment on or make changes to this bug.