App which requires unsupported APIs still listed on marketplace homepage for Android

RESOLVED FIXED in 2013-07-18

Status

Marketplace
Consumer Pages
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: chuck)

Tracking

2013-07-18
Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:
1. Pick an app which is listed on the marketplace homepage like "Twitter"
2. Edit the minimum required API list to include those which are unsupported on Android like "Smartphone-Sized Displays, WebFM, WebM, WebSMS " or load https://marketplace-dev.allizom.org/developers/app/twitter/edit
3. Save changes

expected behavior:
The app is now unsupported on Android and should not be listed on the marketplace homepage for Android

observed behavior:
The app is still listed in the homepage. The app doesn't show up in search results as expected.
(Reporter)

Comment 1

5 years ago
ashes: da5ad
http://f.cl.ly/items/2p1G2H0C2I0p2G1j2U3S/Screen%20Shot%202013-07-10%20at%202.50.19%20PM.png among others lists `'fm': True` and Krupa's profile doesn't support that:

	In [6]: dict(FeatureProfile.from_signature('ca7d57fc.32.1'))
	Out[6]: 
	{'activity': False,
	 'apps': True,
	 'archive': False,
	 'audio': True,
	 'battery': True,
	 'bluetooth': False,
	 'contacts': False,
	 'device_storage': True,
	 'fm': False,
	 'fullscreen': True,
	 'gamepad': False,
	 'geolocation': True,
	 'idle': True,
	 'indexeddb': True,
	 'light_events': True,
	 'mp3': True,
	 'network_info': True,
	 'network_stats': False,
	 'orientation': True,
	 'packaged_apps': True,
	 'pay': False,
	 'proximity': True,
	 'push': False,
	 'qhd': True,
	 'quota': False,
	 'sms': True,
	 'time_clock': False,
	 'touch': True,
	 'vibrate': True,
	 'video_h264': True,
	 'video_webm': True,
	 'webaudio': True}

Smells like a bug
(Reporter)

Updated

5 years ago
Blocks: 858314
Assignee: nobody → charmston
Priority: -- → P2
Target Milestone: --- → 2013-07-18
(Assignee)

Comment 3

5 years ago
Couldn't reproduce, and Krupa confirmed that it's no longer an issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.