Account Settings dialogs should be a fixed size, no scroll bars

RESOLVED FIXED

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Sander van Rijnswou, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

17 years ago
To reproduce

1. Go to Edit -> Mail/News account settings
2. Resize the window. Make it smaller either from the top or from below. 

Result:

The text disappears when the windows becomes to small, but no scrollbars
appear. 

Expected:

I'd expect the window to be either of fixed size or to appear scrollbars.
With the default window size, you do not see 'show confirmation' at the bottom 
of 'Copies ande folders'

Comment 1

17 years ago
As per preferences this dialog should not be resizable.
Looked for a dup but couldn't find one.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
This one HAS a dup... Looking

Comment 3

17 years ago
Well... The dupe is in the Preferences window... Most mozilla windows that lets
you change options have this bug so i dont know if this should remind as a
different bug
For the developers to see:
bug 52298
bug 63236
Changing summary a bit
Summary: Account settings menu is resizable but does not have scrollbars → Mail/News account settings menu is resizable but does not have scrollbars

Comment 4

17 years ago
... an also bug 59108 ?
(Reporter)

Comment 5

17 years ago
I guess that the real problem is that account settings menu is resizable while 
it should not be. The preference menu is also not resizeble.

Maybe the scrollbars are not important. (although one option falls of the 
default size windows)



 

Comment 6

17 years ago
This seems to have become worse since 0.9.2. The different fields are
more-or-less arranged horizontally now...stretching off the right side of the
window. 0.9.2 had everything more-or-less vertical. Perhaps this change had
something to do with it:
http://bonsai.mozilla.org/cvsquery.cgi?branch=HEAD&file=mozilla/mailnews/base/prefs/resources/content/smtpEditOverlay.xul&date=week

Comment 7

17 years ago
*** Bug 93263 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 111315 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
I transfer a note from Jennifer from bug 111315:
 
Additional Comment #2 From jglick@netscape.com 2001-11-21 16:15
Agree. Account Settings dialogs should be a fixed size, just like Prefs.

Summary: Mail/News account settings menu is resizable but does not have scrollbars → Account Settings dialogs should be a fixed size, no scroll bars
OS: Windows NT → All
Hardware: PC → All

Updated

17 years ago
Component: Mail Window Front End → Account Manager
QA Contact: esther → nbaca

Comment 10

17 years ago
*** Bug 96110 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 154249

Comment 11

15 years ago
Adding dependency to bug 57956 ("mailnews account settings dialog isn't
sensitive to font size"), because the dialog shouldn't get a fixed size as long
as the size is not sensitive to the used font size.
Depends on: 57956

Comment 12

15 years ago
Created attachment 133371 [details] [diff] [review]
Patch

This patch fixes this bug and bug 57956. The proposed size is 55em by 44em. I
did some small changes to the chrome to avoid an even bigger size. The largest
page (both width and height) is currently "Offline & Disk Space" for NNTP
accounts. I tested this with both Modern and Classic theme on Windows XP and
Linux (GTK). The Classic theme on Linux needs the most space.

Updated

15 years ago
Attachment #133371 - Flags: review?(neil.parkwaycc.co.uk)

Comment 13

15 years ago
Comment on attachment 133371 [details] [diff] [review]
Patch

First impressions:

> <dialog id="account-manager" 
>         xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
>         title="&accountManagerTitle.label;"
>-        width="&account-manager.width;" height="&account-manager.height;"
>-        persist="screenX screenY width height"
>+        style="&accountManager.size;"
>+        persist="screenX screenY"
The problem here is that old profiles will have the width and height persisted.

>-    <dialogheader id="am-main-title" defaultTitle="&accountTitle.label;"/>
>+    <dialogheader style="overflow: hidden;" id="am-main-title" defaultTitle="&accountTitle.label;"/>
This is now -moz-hidden-unscrollable;

>Index: extensions/help/resources/locale/en-US/mail_help.html
I don't think this is part of the patch.

Comment 14

15 years ago
>>-    <dialogheader id="am-main-title" defaultTitle="&accountTitle.label;"/>
>>+    <dialogheader style="overflow: hidden;" id="am-main-title"
defaultTitle="&accountTitle.label;"/>
>This is now -moz-hidden-unscrollable;

Using -moz-hidden-unscrollable; doesn't work in the respect I wanted it to use.
Perhaps this is because of
http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsBlockReflowContext.cpp#660

The problem I'm tackling here is that the <dialogheader> is to wide when the
Account Name is long. This affects the whole preferences page so it is partial
rendered outside the visible area. With "overflow: hidden" this problem was
gone, using "overflow: -moz-hidden-unscrollable" doesn't fix it.

Updated

15 years ago
Depends on: 222585

Updated

15 years ago
Attachment #133371 - Flags: review?(neil.parkwaycc.co.uk)

Comment 15

15 years ago
Created attachment 133492 [details] [diff] [review]
Patch V1.1

Updated patch. Overflow isn't needed at all when bug 222585 is landed. I'll
update the help files in a separate bug. The id of the dialog is now
accountManager.

Updated

15 years ago
Attachment #133371 - Attachment is obsolete: true

Updated

15 years ago
Attachment #133492 - Flags: review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #133492 - Flags: review?(neil.parkwaycc.co.uk)

Comment 16

15 years ago
Created attachment 133504 [details] [diff] [review]
Patch V1.2

1. Change for consistency: replace "quoted text" with "quote" everywhere.
2. Simplify am-addressing.xul a bit (compared with the last patch).

Updated

15 years ago
Attachment #133492 - Attachment is obsolete: true

Updated

15 years ago
Attachment #133504 - Flags: review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #133504 - Flags: review?(neil.parkwaycc.co.uk) → review+

Comment 17

15 years ago
Comment on attachment 133504 [details] [diff] [review]
Patch V1.2

David: Perhaps you could also take a look at Bug 222585 so these both patches
can go in together?
Attachment #133504 - Flags: superreview?(bienvenu)

Updated

15 years ago
Attachment #133504 - Flags: superreview?(bienvenu) → superreview+

Comment 18

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 19

15 years ago
Well, it seems to break account settings display in Thunderbird.

When going to tools / account settings, got xul error :

style="&accountManager.size;"
---------------^

Comment 20

15 years ago
Created attachment 133596 [details] [diff] [review]
Fix for TB

I don't have a TB build environment, so I can't test this. But I think this is
the necessary change.

Updated

15 years ago
Attachment #133596 - Flags: superreview?(scott)
Attachment #133596 - Flags: review?(scott)

Comment 21

15 years ago
In answer to comment #20 : it's worse :(

When I launch a build with your patch, I got a lot of xul errors :

<window id="messengerWindow"

<menuitem id)"menu_newCard" label="&newCardCmd.label;"
accesskey="&newCardCmd.accesskey;" command="cmd_newCard"/>

and so on for 5 lines. May we open a bug for this issue ?

Comment 22

15 years ago
Frederic: In this case I'm quite sure TB was already broken before this bug was
fixed. You could verify this by backing out "Fix for TB" and "Patch V1.2" from
this bug from your tree. Please file a new bug on Thunderbird.

Comment 23

15 years ago
I will open a new bug. But I am sure that TB wasn't broken before :)

I have a backup of my 16-october TB build which is working. For my tree ? Well,
I can live a little time with an old build.

Comment 24

15 years ago
my last comment here : new bug opened (for TB) : bug 222841.

Comment 25

15 years ago
This fix created bug 222940 (Account Settings window too small)

Comment 26

15 years ago
I checked in the thunderbird change for this bug.

Updated

15 years ago
Attachment #133596 - Flags: superreview?(scott)
Attachment #133596 - Flags: review?(scott)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.