Closed Bug 892247 Opened 10 years ago Closed 10 years ago

Trying to submit a packaged app with an origin specified in which the origin was already included in an already submitted app fails to report a validation error

Categories

(Marketplace Graveyard :: Validation, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 878105

People

(Reporter: jsmith, Unassigned)

Details

Attachments

(1 file)

Attached file Test App
STR

1. Go to https://marketplace-dev.allizom.org/developers/submit/
2. Try to submit the attached packaged app
** Note - Assumes existence of https://marketplace-dev.allizom.org/app/test-webapi-permissions-9. If that doesn't exist, you'll need to submit this app twice.

Expected

The app should fail validation - two packaged apps cannot have the same origin.

Actual

The app passes validation.
This is kind of a Developer Pages bug, but yes it's an interesting one.
Dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=878105 (since it has been re-opened) ?
(In reply to Mathieu Pillard [:mat] from comment #2)
> Dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=878105 (since it has
> been re-opened) ?

Yup.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.