Closed Bug 892337 Opened 11 years ago Closed 11 years ago

Default zoom level inconsistent with other browsers

Categories

(Firefox :: Untriaged, defect)

22 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 851268

People

(Reporter: dallwitz.m, Unassigned)

Details

Attachments

(1 file)

Attached file test.htm
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Viewed simple HTML text. E.g.

<html><body>abc</body></html>


Actual results:

The text is larger than in other browsers.


Expected results:

"The good news is that Firefox now supports high resolution monitors. The bad news is that this may have the effect of making websites look bigger than you're used to."

Firefox now renders text larger than do other browsers such as IE and Opera.

This means that website developers can't make even simple pages look the same in all popular browsers.

This could be regarded as a bug or a (bad) feature. What was the rational for the change?

I don't understand the reference to "support[ing] high resolution monitors". The change affects monitors of all resolutions. I've been using high-resolution monitors for years without any problems - I simply make the appropriate dpi setting in Windows.

The bad effects of the change would be alleviated if (like IE) Firefox supported a zoom factor that applied to all subsequently loaded pages. This should be a built-in feature, as most users probably won't want to go to the trouble of getting an extension to do the job.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Works for me at 100%, 150% and 200%. Text/pages are the same size in Firefox as in IE, Chrome, and Opera. (Note that Chrome and Opera are both fuzzy from DWM scaling.)

I can "replicate" against Opera and Chrome at 125% but the bug is on their end since they don't follow my chosen system DPI scale. The latest Chrome Canary produces the same results as Firefox 22 but has a horribly pixellated UI.

(Instructions to enable HiDPI in Chrome Canary can be found at their HiDPI ticket, http://code.google.com/p/chromium/issues/detail?id=149881#c111 )
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: