Let SitePermissions.jsm handle indexedDB's special use of UNKNOWN_ACTION and ALLOW_ACTION

RESOLVED FIXED in Firefox 25

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 25
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Posted patch patchSplinter Review
I believe this matches what bent described in bug 889835. I also fixed a typo in SitePermissions.remove.
Attachment #773835 - Flags: review?(jaws)
Comment on attachment 773835 [details] [diff] [review]
patch

Review of attachment 773835 [details] [diff] [review]:
-----------------------------------------------------------------

On a side topic, could we add a migration step that fixes the pre-existing permissions to not have to use this confusing redefinition?
Attachment #773835 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] from comment #1)
> On a side topic, could we add a migration step that fixes the pre-existing
> permissions to not have to use this confusing redefinition?

The problem is that indexedDB wants the absence of a saved state to mean "allow" (which by itself is ok, other permissions have the same behavior) but at the same time provide an opt-in "ask me every time" state. We'd have to either stop supporting that option (users could still pick "block" for sites they don't trust) or introduce a new state for it like nsIPermissionManager::ASK_ACTION.
https://hg.mozilla.org/mozilla-central/rev/600aee747c40
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.