http://gismap.taichung.gov.tw/ doesn't show maps in any Linux browser

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: jidanni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130705 Firefox/24.0 Iceweasel/24.0a2 (Nightly/Aurora)
Build ID: 20130705004019

Steps to reproduce:

On a pristine Linux account
(# su - nobody -c 'HOME=/tmp/$$;mkdir $HOME; firefox '$URL )
(So don't tell me to try safe-mode, etc.)
I visited http://gismap.taichung.gov.tw/
and clicked the area just above the word WELCOME which says
http://gismap.taichung.gov.tw/address/images/btn_enter.png


Actual results:

No map appeared at the right. Thus this site is unusable.



Expected results:

The site should work fine like it does in Chromium. 27.0.1453.110-2

Comment 2

5 years ago
WFM with FF25 on Win 7: http://i.imgur.com/tqyXxyp.jpg

Do you see some error messages in the console?
(Reporter)

Comment 3

5 years ago
Indeed upon further testing I find it must be a timing issue.
I discovered that on about one out of four firefox runs the map does indeed appear.
And yes. In the CTRL-SHIFT-K console, besides 'Error in parsing value...' and 'Unknown property...' that I'm sure you also see,
on SUCCESSFUL runs I also see

[12:11:44.239] GET http://gismap.taichung.gov.tw/Geo4Oracle/mapviewerphp/legend.php?LC=0&MAPNAME=MAP3&SESSION=05a19d48-eaa9-11e2-8000-002219b49672_en_C0A802550AFC0AFB0AFA&LAYERS= [HTTP/1.1 200 OK 4210ms]
[12:11:47.404] POST http://gismap.taichung.gov.tw/Geo4Oracle/G4O/Default/Main/Map/mgAction.php [HTTP/1.1 200 OK 527ms]
[12:11:47.415] POST http://gismap.taichung.gov.tw/Geo4Oracle/mapagent/mapagent.fcgi [HTTP/1.1 200 OK 503ms]
[12:11:47.873] GET http://gismap.taichung.gov.tw/Geo4Oracle/mapagent/mapagent.fcgi?OPERATION=GETDYNAMICMAPOVERLAYIMAGE&FORMAT=PNG&VERSION=1.0.0&SELECTION=&SESSION=081acb4e-eaa9-11e2-8000-002219b49672_en_C0A802550AFC0AFB0AFA&MAPNAME=MAP_INDEX_3857&SEQ=0.8827790701355133&SETVIEWSCALE=1800000&SETVIEWCENTERX=13460941&SETVIEWCENTERY=2781313&SETDISPLAYWIDTH=235&SETDISPLAYHEIGHT=110&CLIENTAGENT=Ajax%20Viewer [HTTP/1.1 200 OK 1348ms]

But on unsuccessful runs those are absent.
(Reporter)

Comment 4

5 years ago
Chromium however works on every run, displaying the 'waiting for...' So Firefox doesn't wait enough properly apparently. P.S., I only have Linux.
WFM with the latest Nightly, build ID: 20130714030202, on Ubuntu 12.10 32bit

Could you please try this with a clean profile, to see if you still reproduce the issue: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Updated

5 years ago
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
(Reporter)

Comment 6

3 years ago
Now they have redesigned the site.
However looking up an address still just shows a blank area with map missing.
You will need a Chinese speaker to test this.
Version 42.0a2 (2015-09-06) on Debian Linux.
(Reporter)

Comment 7

3 years ago
Created attachment 8661782 [details]
d.jpg
(Reporter)

Comment 8

3 years ago
By the way I have the same problem now (can't see any maps when clicking the 2D globe icons after searching for a place) in Chromium 46.0.2490.13-1 here on Debian sid.
(Reporter)

Updated

3 years ago
Summary: http://gismap.taichung.gov.tw/ works in Google Chrome but not Firefox → http://gismap.taichung.gov.tw/ doesn't show maps in any Linux browser
I'm not able to reproduce this on my computer running Debian and Firefox 42.0a2. Perhaps you could provide more details about your system configuration as there's probably some other variable we're missing here.

That said, I think this is an issue that the website developer needs to fix. For now I'm going to move this to Tech Evangelism.
Component: Canvas: WebGL → Desktop
Product: Core → Tech Evangelism
Version: 24 Branch → unspecified
(Reporter)

Comment 10

3 years ago
OK .(Well you would have to be able to read Chinese to get to the part of the site that I am now still complaining about (
https://www.facebook.com/groups/Debian.zh/838856276212463/ ))
Dan, could you post step-by-step instructions?
(Reporter)

Comment 12

3 years ago
You need to have a Chinese member of your staff read https://www.facebook.com/groups/Debian.zh/838856276212463/ .

Else you are looking at 1000 times more effort.

Just tell a Chinese member of your staff to search for any address and then hit a blue 2D glove icon.

Every step of the way rest until the CPU meter indicated whatever is loading has finished loading, else you won't even see the background map.
The site seems to be working for me.
If there are new issues with this site which do not happen in other browsers please open a new bug.
https://webcompat.com/

Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.