application id 398736 is empty in export API

RESOLVED FIXED in 2013-08-13

Status

Marketplace
API
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nati, Assigned: ashort)

Tracking

2013-08-13
Points:
---

Details

(Whiteboard: [qa-])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31

Steps to reproduce:

Downloaded the latest export from prod:
https://marketplace.cdn.mozilla.net/dumped-apps/tarballs/2013-07-10.tgz



Actual results:

The file: `apps/398/398736.json` is empty


Expected results:

As it's available via:
https://marketplace.firefox.com/api/v1/apps/app/398736/?format=JSON
and was created almost a year ago, I guess it shouldn't be empty.
(Reporter)

Comment 1

5 years ago
This might be related to https://bugzilla.mozilla.org/show_bug.cgi?id=882072
(Reporter)

Updated

5 years ago
Component: General → API

Updated

5 years ago
Priority: -- → P1
On IRC:
> Hey. I'm mucking around with Firefox Marketplace's daily dumps and I've encountered some empty .json files. I think there might be a problem with your export script.
> I'm talking about the script that produces https://marketplace.cdn.mozilla.net/dumped-apps/tarballs/2013-07-16.tgz and the like
> For example, in today's dump the .json file for app 409334 is empty.
> It was fine on the 14th and 13th, and possibly earlier, too.
> I believe it's a problem with the export script because it works just fine via the API: https://marketplace.firefox.com/api/v1/apps/app/409334/
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

5 years ago
Assignee: nobody → ashort
(Assignee)

Comment 3

5 years ago
running the export script locally, I have not been able to reproduce this. This isn't a failure of generating the data, since the export script completes successfully. My only guess at this point is that there's some failure between the data being generated and the tarball being written. Could this be an NFS-related problem?
(Assignee)

Comment 4

5 years ago
see bug 886987
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-08-01
(Assignee)

Comment 5

5 years ago
oops wrong bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/8065550
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: 2013-08-01 → 2013-08-15
(Assignee)

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.