Crash when pasting text from clipboard into etherpad [@ mozalloc_abort(char const*) | NS_DebugBreak | X11Error]

RESOLVED DUPLICATE of bug 888670

Status

()

Core
Editor
--
critical
RESOLVED DUPLICATE of bug 888670
5 years ago
5 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({crash})

24 Branch
All
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

I tried to paste some clipboard content into an etherpad and Firefox crashed. It's not reproducible so far.

Report: bp-643896fd-ea45-4f34-8e27-5da2b2130711

Stack:
0 	libmozalloc.so 	mozalloc_abort(char const*) 	memory/mozalloc/mozalloc_abort.cpp
1 	libxul.so 	NS_DebugBreak 	xpcom/base/nsDebugImpl.cpp
2 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp
3 	libX11.so.6.3.0 	_XError 	../../src/XlibInt.c
4 	libX11.so.6.3.0 	handle_error 	../../src/xcb_io.c
5 	libX11.so.6.3.0 	handle_response 	../../src/xcb_io.c
6 	libX11.so.6.3.0 	_XEventsQueued 	../../src/xcb_io.c
7 	libX11.so.6.3.0 	XCheckIfEvent 	../../src/ChkIfEv.c
8 	libxul.so 	wait_for_retrieval 	widget/gtk2/nsClipboard.cpp
9 	libxul.so 	wait_for_contents 	widget/gtk2/nsClipboard.cpp
10 	libxul.so 	nsClipboard::HasDataMatchingFlavors(char const**, unsigned int, int, bool*) 	widget/gtk2/nsClipboard.cpp
11 	libxul.so 	nsHTMLEditor::HavePrivateHTMLFlavor(nsIClipboard*) 	editor/libeditor/html/nsHTMLDataTransfer.cpp
12 	libxul.so 	nsHTMLEditor::Paste(int) 	editor/libeditor/html/nsHTMLDataTransfer.cpp
[..]

Comment 1

5 years ago
Let's reopen bug 888670.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 888670
You need to log in before you can comment on or make changes to this bug.