Intermittent Halting on failure while running ['/tools/buildbot/bin/python', '/tools/misc-python/virtualenv.py', '--no-site-packages', '--distribute', '/Users/cltbld/talos-slave/test/build/venv'] (OSError ... pip-0.8.2.tar.gz failed with error code 2)

RESOLVED WORKSFORME

Status

Release Engineering
General Automation
RESOLVED WORKSFORME
5 years ago
7 months ago

People

(Reporter: emorley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozharness])

(Reporter)

Description

5 years ago
Rev4 MacOSX Lion 10.7 mozilla-central debug test crashtest on 2013-07-11 03:33:09 PDT for push 82fafd8ee40f

slave: talos-r4-lion-049

https://tbpl.mozilla.org/php/getParsedLog.php?id=25164405&tree=Mozilla-Central

{
03:34:59     INFO - #####
03:34:59     INFO - ##### Running create-virtualenv step.
03:34:59     INFO - #####
03:34:59     INFO - Creating virtualenv /Users/cltbld/talos-slave/test/build/venv
03:34:59     INFO - Running command: ['/tools/buildbot/bin/python', '/tools/misc-python/virtualenv.py', '--no-site-packages', '--distribute', '/Users/cltbld/talos-slave/test/build/venv'] in /Users/cltbld/talos-slave/test/build
03:34:59     INFO - Copy/paste: /tools/buildbot/bin/python /tools/misc-python/virtualenv.py --no-site-packages --distribute /Users/cltbld/talos-slave/test/build/venv
03:35:00     INFO -  Using real prefix '/System/Library/Frameworks/Python.framework/Versions/2.7'
03:35:00     INFO -  New python executable in /Users/cltbld/talos-slave/test/build/venv/bin/python
03:35:01     INFO -  Installing distribute...................done.
03:35:01     INFO -    Complete output from command /Users/cltbld/talos-slave/test...ython /Users/cltbld/talos-slave/test...stall /tools/misc-python/pip-0.8.2.tar.gz:
03:35:01     INFO -    /Users/cltbld/talos-slave/test/build/venv/bin/python: can't open file '/Users/cltbld/talos-slave/test/build/venv/bin/easy_install': [Errno 2] No such file or directory
03:35:01     INFO -  ----------------------------------------
03:35:01    ERROR -  Traceback (most recent call last):
03:35:01     INFO -    File "/tools/misc-python/virtualenv.py", line 1647, in <module>
03:35:01     INFO -      main()
03:35:01     INFO -    File "/tools/misc-python/virtualenv.py", line 558, in main
03:35:01     INFO -      prompt=options.prompt)
03:35:01     INFO -    File "/tools/misc-python/virtualenv.py", line 656, in create_environment
03:35:01     INFO -      install_pip(py_executable)
03:35:01     INFO -    File "/tools/misc-python/virtualenv.py", line 415, in install_pip
03:35:01     INFO -      filter_stdout=_filter_setup)
03:35:01     INFO -    File "/tools/misc-python/virtualenv.py", line 624, in call_subprocess
03:35:01     INFO -      % (cmd_desc, proc.returncode))
03:35:01     INFO -  OSError: Command /Users/cltbld/talos-slave/test...ython /Users/cltbld/talos-slave/test...stall /tools/misc-python/pip-0.8.2.tar.gz failed with error code 2
03:35:01    ERROR - Return code: 1
03:35:01    FATAL - Halting on failure while running ['/tools/buildbot/bin/python', '/tools/misc-python/virtualenv.py', '--no-site-packages', '--distribute', '/Users/cltbld/talos-slave/test/build/venv']
}
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Reporter)

Comment 1

4 years ago
Intermittent failure not seen for >3 months; filter on mass-intermittent-wfm-20140812.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 9

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 4
* mozilla-inbound: 2

Platform breakdown:
* osx-10-10: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=892446&startday=2016-05-30&endday=2016-06-05&tree=all

Comment 10

11 months ago
8 failures in 812 pushes (0.01 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* mozilla-inbound: 8

Platform breakdown:
* osx-10-10: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=892446&startday=2017-02-20&endday=2017-02-26&tree=all
(Reporter)

Comment 11

11 months ago
Tomcat, the failures classified against this in comment 10 were not related.

Please double check the logs when classifying against resolved worksforme bugs :-)

Comment 12

7 months ago
6 failures in 864 pushes (0.007 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 5
* mozilla-inbound: 1

Platform breakdown:
* osx-10-10: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=892446&startday=2017-06-05&endday=2017-06-11&tree=all
(Reporter)

Comment 13

7 months ago
(In reply to Ed Morley [:emorley] from comment #11)
> Tomcat, the failures classified against this in comment 10 were not related.
> 
> Please double check the logs when classifying against resolved worksforme
> bugs :-)

Tomcat, same again now for comment 12 - these recent failures aren't related.
Please don't classify against closed bugs without reading the logs carefully.

In this case I'm sure the problem isn't helped by the use of pip 1.5.5 -- I'd try and get releng to update to 9.x first.
Flags: needinfo?(cbook)
(Reporter)

Updated

7 months ago
Keywords: intermittent-failure
ok thank you Ed!
Flags: needinfo?(cbook)
You need to log in before you can comment on or make changes to this bug.