Use bedrock plugincheck page for locales

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: pascalc, Assigned: pascalc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1049864] )

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
The plugincheck page was migrated from PHP to bedrock in English, the localizers are working on updating their copy now and we can replace the php-powered localized plugincheck pages by the bedrock power pages until they are all migrated and we can then delete the old versions on svn.

I propose that we start with a few minor languages so as to make sure we don't hit on production a bug that only affect locales.

The first set will be: eu, is, sv-SE

Let's keep this bug open so as to track all the other locales to activate instead of filing new bugs.

This is similar to the work in bug 881754 for firefox/new, I can make the pull requests to update our global.cong file myself now that we have an example set.

Thanks
(Assignee)

Updated

6 years ago
Summary: Use bedrock /new page for locales → Use bedrock plugincheck page for locales
(Assignee)

Comment 1

6 years ago
Created attachment 773948 [details]
Pointer to Github pull request: https://github.com/mozilla/bedrock/pull/1048

Pointer to Github pull-request

Comment 2

6 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/df8c631ce6e94cff2d3990a0d5675a5fb2dc3bf8
Bug 892470: plugincheck, activate eu, is, sv-SE locales

https://github.com/mozilla/bedrock/commit/2576a201339ae0cd460e04499d2c2b93ce888204
Merge pull request #1048 from pascalchevrel/bug892470-plugincheck_actvate_locales
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
Keeping open as I will track all locales migration through this bug as well as the deletion of the old plugincheck static pages on the php site as we convert locales to python.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

6 years ago
Old PHP plugincheck pages deleted for sv-SE, eu, is in svn in :
r117972 (trunk) r117973 (stage) r117974 (production)

Comment 6

6 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/b07a86f80b2cee1fc80a30480c040344c82dfaf3
Merge pull request #1057 from pascalchevrel/bug892470-plugincheck_actvate_locales

Bug 892470
(Assignee)

Comment 9

6 years ago
we have more locales to come
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
adding to kanban board
Priority: -- → P2
Whiteboard: [kb=1049864]
(Assignee)

Comment 11

6 years ago
locales ready:
cs
csb
da
eo
es-AR
es-CL
hy-AM
ko
mk
ru
sk
sq

Waiting on a yes/no in bug 894812 before writing a patch to activate them.
Depends on: 894812
(Assignee)

Comment 12

6 years ago
Created attachment 780923 [details]
Pointer to Github pull request: https://github.com/mozilla/bedrock/pull/1105

Pointer to Github pull-request
(Assignee)

Comment 13

6 years ago
Updated PR to add these locales:
ast, cs, csb, da, eo, es-AR, es-CL, es-ES, hy-AM, ko, mk, pt-BR, ru, sk, sl, sq

Comment 14

6 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/d532a9159956265081e842d95d4d199b55009b2e
Bug 892470 : activate more locales for plugincheck

https://github.com/mozilla/bedrock/commit/6279ac9fb9f2e26ae37cb0e2fc081d2b5953d4d1
Merge pull request #1105 from pascalchevrel/bug892470-plugincheck_actvate_locales

Bug 892470 : activate more locales for plugincheck
Created attachment 781520 [details]
Pointer to Github pull request: https://github.com/mozilla/bedrock/pull/1109

Pointer to Github pull-request

Comment 16

6 years ago
Created attachment 782139 [details]
Problem in search query!

Please fix this :
This is an example of the problem when the user search for "Google Update" plugin:

--> Before : 

en-US = current version plugin Google Update
fr    = version actuelle du plugin google update 
it    = versione corrente plugin google update
ru    = текущая версия плагина Google Update

--> But now :

en-US = current version plugin Google Update
fr    = current version plugin Google Update
it    = current version plugin Google Update
ru    = current version plugin Google Update



Non English users will have difficulty if the search query is in English!

Comment 17

6 years ago
Comment on attachment 782139 [details]
Problem in search query!

>Problem in search query!

Please fix this :
This is an example of the problem when the user search for "Google Update" plugin:

--> Before : 

en-US = current version plugin Google Update
fr    = version actuelle du plugin google update 
it    = versione corrente plugin google update
ru    = текущая версия плагина Google Update

--> But now :

en-US = current version plugin Google Update
fr    = current version plugin Google Update
it    = current version plugin Google Update
ru    = current version plugin Google Update



Non English users will have difficulty if the search query is in English!
Ayman, please don't comment in this kind of bugs, they're used to track the progress of the localization work.

If you find problems with the page, please file a new bug (product: www.mozilla.org, component: Bedrock) describing the issue and with detailed instructions to reproduce the problem, because honestly I can't understand your previous comments.
Attachment #782139 - Attachment is obsolete: true

Comment 19

6 years ago
HI Francesco, thank you for your replay and sorry if i commented in a wrong place.

I just want to report a problem about the last modifications made on plugincheck pages. 

for example before the modification, when a French Firefox user goes to this page:
https://www.mozilla.org/fr/plugincheck/
to check for Unknown Plugins
 when the user clicks on one of the blue buttons, this will take him to a Google search page with a search query like this : "version actuelle du plugin google update"
the search query was in french language but after the modification made on the plugincheck pages, the search query is now in english language, this is the problem because a french firefox user will not understand English linguage.(the same problem for other languages)

Please fix this problem or tell me how to report it.

Thanks an sorry :)
Thanks Ayman, now I get the issue and I think it's great feedback :-)

I've opened bug 898766 to track this issue and you're already CCed on that.

Comment 21

6 years ago
thanks thanks thanks :)

Comment 23

5 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/a8e305a12279d31ea128ebc49488fa00220d6801
Merge pull request #1134 from pascalchevrel/bug892470-plugincheck_actvate_locales

Bug 892470 - Use bedrock plugincheck page for locales
(In reply to AYMAN from comment #21)
> thanks thanks thanks :)

There is already an open pull request for this in https://bugzilla.mozilla.org/show_bug.cgi?id=898766#c7
Depends on: 904002

Comment 25

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/d5f0cec4c0093e9f6d62b3b5a854c42136853efa
Bug 892470 : add nl+ja locales to plugincheck

https://github.com/mozilla/bedrock/commit/8d34b024aedd0fe59bc1ea075f3774ebe41913fe
Merge pull request #1148 from pascalchevrel/bug892470-plugincheck_actvate_locales

Bug 892470 : add nl locale to plugincheck
(Assignee)

Comment 27

5 years ago
(In reply to raymond [:retornam] from comment #26)

> 
> https://www.allizom.org/nl/plugincheck/ ---> shows old page


https://github.com/mozilla/bedrock/compare/b46b64c29122c024941c1ac3075f93647e6cba9c...master

nl+ja update not on allizom.org

Comment 28

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5c7b5d2e2dbfb352de34f0a18547168248bf1b24
Bug 892470 - enable plugincheck for pt-PT, rm, tr

Note: don't close the bug when merged, it's used to track activations
for all locales.

https://github.com/mozilla/bedrock/commit/6d152cdc1736d7e6de2c59850ee2cbdc11824289
Merge pull request #1174 from flodolo/plugincheck_trpt

Bug 892470 - enable plugincheck for pt-PT, rm, tr

Comment 30

5 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/b1278b912022e1f42925d48ad02dd8f2191ea556
Enable /plugincheck and /new for nb-NO

Updated rewrite rule to enable plugincheck (bug 892470) and new
download page (bug 881754) for nb-NO
The above was tested by me- I forgot I was signed in as a test user [I'd been testing Persona....]

Comment 36

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/257bc78eee19f18703812452b162843e7cacbd88
Bug 892470: enable more locales for plugincheck

List of new locales: an, cy, ff, fi, ga-IE, ka, ml, ro, te.

https://github.com/mozilla/bedrock/commit/96db39fb0b86ebd1c1b45b729555fbdd62b68495
Merge pull request #1234 from flodolo/plugincheck_newlocales

Bug 892470: enable more locales for plugincheck

Comment 38

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/620d449ba108fdacd8379bcc8dccbe1c98135cd1
Bug 892470: activate pluguncheck for hr and es-MX

https://github.com/mozilla/bedrock/commit/d96760bb1f9539accb30c62eb7a628727d14577c
Merge pull request #1242 from pascalchevrel/bug892470-plugincheck_actvate_locales

Bug 892470: activate pluguncheck for hr and es-MX

Comment 40

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/a6e3d3bf2119c815fa95c2ccc56e9788daff0e42
Bug 892470: enable plugincheck redirect for kk

https://github.com/mozilla/bedrock/commit/c800c1120a80b6b2b42078395ef447cb87f88134
Merge pull request #1247 from flodolo/kk_plugincheck

Bug 892470: enable plugincheck redirect for kk

Comment 41

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/3359363d859bf553cd31a7e524393e38eb03dd35
Bug 892470: enable plugincheck redirect for zh-CN

https://github.com/mozilla/bedrock/commit/7fffbe8764f0f58bf7599309d6c64068dec2114c
Merge pull request #1253 from flodolo/zhcn_plugincheck

Bug 892470: enable plugincheck redirect for zh-CN

Comment 42

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/bf8f3bf2638dbc038ba3a8956d2a3fd17421778c
Bug 892470: enable plugincheck redirect for fy-NL

https://github.com/mozilla/bedrock/commit/32d901970286863057e3de261fee3392bc146921
Merge pull request #1256 from flodolo/fynl_plugincheck

Bug 892470: enable plugincheck redirect for fy-NL

Comment 43

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/33bcdf78d2cad35f443bcc0c779b77f02ea216a8
Bug 892470: enable plugincheck redirect for son

https://github.com/mozilla/bedrock/commit/89caba9969a846e01da6d061696440bba0e5e7f7
Merge pull request #1259 from flodolo/son_plugincheck

Bug 892470: enable plugincheck redirect for son

Comment 46

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/89c73742c2cd8503ad80a856810826601e548c6f
Bug 892470: enable plugincheck redirect for ca, he

https://github.com/mozilla/bedrock/commit/ad3870f3fbe5bede49ce58fd33db994827fea56c
Merge pull request #1277 from flodolo/plugincheck_cahe

Bug 892470: enable plugincheck redirect for ca, he

Comment 48

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/c356f6e2fad1fd70c4b0d313cada5b92bfe242e8
Bug 892470: enable plugincheck redirect for af, bn-IN, br, gd, ku, lt, ms, th, vi

https://github.com/mozilla/bedrock/commit/1bdffb5f7eb049dcea803b12d5b54bb06e47eb4c
Merge pull request #1349 from pascalchevrel/Bug-892470_enable_plugincheck_redirect

Bug 892470: enable plugincheck redirect for af, bn-IN, br, gd, ku, lt, ms, th, vi

Comment 52

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/e22e5b183cd81bc35eecbcd638017afbf2ac2342
Fix Bug 892470: activate hi-IN and fa plugincheck

https://github.com/mozilla/bedrock/commit/bf3b6d138da41ca3ac46807748a12a067643502c
Merge pull request #1370 from jgmize/bug-892470-plugincheck-hi-IN-fa

Fix Bug 892470: activate hi-IN and fa plugincheck

Updated

5 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago

Comment 54

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/26a332597b3f5a3d01586253ef25c51c52533f8d
Bug 892470: add more plugincheck redirects

Have bedrock handle these locales which are deleted on svn:
ak, en-GB, mai, my, nn-NO, nso, oc, sw, ta, ta-LK, ur, wo

These locales won't get updated any time soon and some are not shipped, it's better to fallback to the bedrock en-US plugincheck page than the old mozilla.com one

https://github.com/mozilla/bedrock/commit/e6d466298d7236e8fb42615900e5f6ce938f7a97
Merge pull request #1374 from pascalchevrel/Bug-892470_plugincheck_redirects_l10n

Bug 892470: add more plugincheck redirects
ak, en-GB, mai, nn-NO nso, oc, sw, ta, ta-LK, ur, wo --->  https://www.allizom.org/en-US/plugincheck/

my --. https://www.allizom.org/my/plugincheck/
ak, en-GB, mai, nn-NO nso, oc, sw, ta, ta-LK, ur, wo --->  https://www.mozilla.org/en-US/plugincheck/

my -> https://www.mozilla.org/my/plugincheck/
Status: RESOLVED → VERIFIED

Comment 58

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/efb51c91ecae971cb70655f1b31d078084ae2e9c
Bug 892470 - Enable /new for more locales

Added locales: ku, oc, ur

https://github.com/mozilla/bedrock/commit/9570f0b2db9f47be494e030ea3f4a57804b7ecc9
Merge pull request #1493 from flodolo/new_dec6

Bug 892470 - Enable /new for more locales

Comment 65

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5c8fe7e77350bced2341af33cc811035d8177e6f
Bug 892470 - Enable bedrock plugincheck for be

https://github.com/mozilla/bedrock/commit/b7194d990ee33fcb7b69f9faf576718c3984869a
Merge pull request #1838 from flodolo/plugincheck_be

Bug 892470 - Enable bedrock plugincheck for be

Comment 67

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/91811dd66b65ddf75a6280c76f6b20f01f951fcf
Bug 892470: redirect all locales for plugincheck to bedrock

https://github.com/mozilla/bedrock/commit/d936b8cd6b7b158bbf316ecd2d8143f758018790
Merge pull request #1972 from pascalchevrel/bug-892470-redirect-plugincheck-all-locales

Bug 892470: redirect all locales for plugincheck to bedrock
(Assignee)

Comment 68

5 years ago
ALL locales are now served from Bedrock (77 locales activated), the older plugincheck pages in PHP were all deleted
You need to log in before you can comment on or make changes to this bug.