Closed Bug 892499 Opened 6 years ago Closed 6 years ago

When findbar can't find any results, there is disturbing overline over the text

Categories

(Toolkit :: Themes, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla25

People

(Reporter: smaug, Assigned: mikedeboer)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

The overline make it really hard to read the text user has just typed.
Olli, is this on all platforms? Could you attach a screenshot for us? Thanks!
Flags: needinfo?(bugs)
Attached image when text is found
Flags: needinfo?(bugs)
This is on linux. Apparently doesn't happen on OSX. Don't know about windows
Okay, thanks a ton! I'll check it out as soon as possible.
This is some recent-ish regression.
This is awful. I looked at this, but I didn't see any text-decoration: line-through. Maybe this is somehow done with borders?
jlebar was seeing this, too.
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
And here I thought this was intentional.  :)
I can't reproduce this at all :( I'm running Ubuntu 13.04, 64bit. Is there another OS I should be checking to get this behavior?
Flags: needinfo?(bugs)
I can reproduce it with the same setup.

> .findbar-textbox[status="notfound"] {
>   box-shadow: 0 0 0 1em #f66 inset;
>   color: white;
> }

FTR, if I change the 1em to 1.1em the issue seems gone. Not sure what that tells us.
Dão, here - http://hg.mozilla.org/mozilla-central/diff/ce23b9b734c0/toolkit/themes/gnomestripe/global/findBar.css - you introduced the use of box-shadow to colorize the background of the text input to red/ yellow. Why did you choose that instead of background-color?

For reference: Bug 483378 from four years ago(!)
Flags: needinfo?(dao)
Flags: needinfo?(bugs)
(13:36:24) dao: we couldn't use background-color as it wouldn't work on natively styled text fields. now we could.
Flags: needinfo?(dao)
Blocks: 776708
Component: General → Themes
Keywords: regression
Product: Firefox → Toolkit
Attachment #778426 - Attachment description: bug-892499-linuxFindOdd.patch → Patch 1: use background-color instead of box-shadow to prevent drawing glitches
Comment on attachment 778426 [details] [diff] [review]
Patch 1: use background-color instead of box-shadow to prevent drawing glitches

Can you do this for all platforms?
Attachment #778426 - Flags: review?(dao)
OSX already uses background-color, so I didn't need to change anything there.
Attachment #778426 - Attachment is obsolete: true
Attachment #779706 - Flags: review?(dao)
Attachment #779706 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/67f117684441
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
QA Contact: manuela.muntean
Verified as fixed with the latest Aurora (build ID: 20130903004001) on Ubuntu 13.04 64bit, while testing for the pre-beta sign-off of the Find Bar Redesign feature.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.