org.mozilla.gecko.GeckoApp$SessionRestoreException: Could not read from session file

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

25 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
07-11 12:42:03.316 I/ProfileMigrator(15986): Opening path: /data/data/org.mozilla.fennec/files/mozilla/mzud3xxr.default/places.sqlite
07-11 12:42:03.316 I/ProfileMigrator(15986): No database
07-11 12:42:03.316 I/GeckoAxis(15986): Prefs: 0.85,0.97,10.0,0.1,0.04,0.3,0.5
07-11 12:42:03.326 E/GeckoApp(15986): An error occurred during restore
07-11 12:42:03.326 E/GeckoApp(15986): org.mozilla.gecko.GeckoApp$SessionRestoreException: Could not read from session file
07-11 12:42:03.326 E/GeckoApp(15986): 	at org.mozilla.gecko.GeckoApp.restoreSessionTabs(GeckoApp.java:1615)
07-11 12:42:03.326 E/GeckoApp(15986): 	at org.mozilla.gecko.GeckoApp.initialize(GeckoApp.java:1427)
07-11 12:42:03.326 E/GeckoApp(15986): 	at org.mozilla.gecko.GeckoApp.onWindowFocusChanged(GeckoApp.java:1953)
07-11 12:42:03.326 E/GeckoApp(15986): 	at com.android.internal.policy.impl.PhoneWindow$DecorView.onWindowFocusChanged(PhoneWindow.java:2840)
07-11 12:42:03.326 E/GeckoApp(15986): 	at android.view.View.dispatchWindowFocusChanged(View.java:7807)
07-11 12:42:03.326 E/GeckoApp(15986): 	at android.view.ViewGroup.dispatchWindowFocusChanged(ViewGroup.java:999)
07-11 12:42:03.326 E/GeckoApp(15986): 	at android.view.ViewRootImpl$ViewRootHandler.handleMessage(ViewRootImpl.java:3446)
07-11 12:42:03.326 E/GeckoApp(15986): 	at android.os.Handler.dispatchMessage(Handler.java:99)
07-11 12:42:03.326 E/GeckoApp(15986): 	at android.os.Looper.loop(Looper.java:137)
07-11 12:42:03.326 E/GeckoApp(15986): 	at android.app.ActivityThread.main(ActivityThread.java:5368)
07-11 12:42:03.326 E/GeckoApp(15986): 	at java.lang.reflect.Method.invokeNative(Native Method)
07-11 12:42:03.326 E/GeckoApp(15986): 	at java.lang.reflect.Method.invoke(Method.java:525)
07-11 12:42:03.326 E/GeckoApp(15986): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1046)
07-11 12:42:03.326 E/GeckoApp(15986): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:862)
07-11 12:42:03.326 E/GeckoApp(15986): 	at dalvik.system.NativeStart.main(Native Method)

--
Samsung Galaxy SIV (Android 4.3)
Nightly (08/11)
(Reporter)

Comment 1

5 years ago
Whoops, this happens on new profile. Was seeing this in my logs. Probably harmless?
Keywords: dataloss
Yeah, it should be harmless in this case, but we shouldn't be seeing this unless something went wrong restoring the session, and especially not on a new profile.
Assignee: nobody → bnicholson
I see this SessionRestoreException in logcat when running a clean install of Nightly 26 for the first time. You can reproduce this by uninstalling and reinstalling Nightly or by going to "Settings > Apps > Nightly > Clear data".

An error occurred during restore
org.mozilla.gecko.GeckoApp$SessionRestoreException: Could not read from session file
 at org.mozilla.gecko.GeckoApp.restoreSessionTabs(GeckoApp.java:1603)
 at org.mozilla.gecko.GeckoApp.initialize(GeckoApp.java:1410)
 at org.mozilla.gecko.GeckoApp.onWindowFocusChanged(GeckoApp.java:1966)
 at com.android.internal.policy.impl.PhoneWindow$DecorView.onWindowFocusChanged(PhoneWindow.java:2709)
 at android.view.View.dispatchWindowFocusChanged(View.java:7447)
 at android.view.ViewGroup.dispatchWindowFocusChanged(ViewGroup.java:930)
 at android.view.ViewRootImpl$ViewRootHandler.handleMessage(ViewRootImpl.java:2927)
 at android.os.Handler.dispatchMessage(Handler.java:99)
 at android.os.Looper.loop(Looper.java:137)
 at android.app.ActivityThread.main(ActivityThread.java:5227)
 at java.lang.reflect.Method.invokeNative(Native Method)
 at java.lang.reflect.Method.invoke(Method.java:511)
 at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:795)
 at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:562)
 at dalvik.system.NativeStart.main(Native Method)
Assignee: bnicholson → nobody
I can reproduce the issue by
1. Clear the data of Fennec using Android system UI.
2. Start Fennec again.

But this error is cached and handled.
I'm not sure if this bug should still keep opening?
Flags: needinfo?(s.kaspari)
(In reply to Nevin Chen [:nechen] from comment #4)
> I can reproduce the issue by
> 1. Clear the data of Fennec using Android system UI.
> 2. Start Fennec again.
> 
> But this error is cached and handled.

Sorry for a typo here, s/cached/catched

> I'm not sure if this bug should still keep opening?
Yeah, this is expected if there's just no session (on first start, after clearing the app data or if you just do not keep a session). I'm going to close this bug.

We could open a new bug and make sure that we either do not log this as an error (because it's confusing if it's an expected state) and/or improve the log message to be more clear - do we even need the stack trace here?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(s.kaspari)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.