Closed Bug 892560 Opened 6 years ago Closed 6 years ago

[inspector] reloading the page breaks the inspector

Categories

(DevTools :: Inspector, defect, P1)

25 Branch
x86_64
Linux
defect

Tracking

(firefox24 unaffected, firefox25+ verified)

VERIFIED FIXED
Firefox 25
Tracking Status
firefox24 --- unaffected
firefox25 + verified

People

(Reporter: julienw, Assigned: paul)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

STR:
* open a webpage
* open the dev tools
* open the inspector tab
* reload the page

=> the inspector tab is irresponsive
=> trying to close the dev tools doesn't work

The only way to recover is to restart the browser.
QA Contact: paul
Assignee: nobody → paul
QA Contact: paul
Exceptions:

--
[13:48:05.664] TypeError: this._walker is null @ resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/inspector/selection.js:122
--
[13:51:35.042] TypeError: this.undo is undefined @ resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/markupview/markup-view.js:646
Assignee: paul → nobody
Duplicate of this bug: 892028
Duplicate of this bug: 892690
good=2013-07-04
bad=2013-07-05
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dcbbfcdf7bb4&tochange=17fe59f6c54a

Browser console after clicking on the close button:
[00:47:41.222] TypeError: this.undo is undefined @ resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/markupview/markup-view.js:646

Suspected bug:
Michael Ratcliffe — Bug 852996 - MarkupView leaks the whole Inspector after being closed r=dcamp
Version: 21 Branch → 25 Branch
Attached patch Patch v1 (obsolete) — Splinter Review
This patch fixes 3 things:
- if a panel fails to close, it should not stop the toolbox to get destroyed;
- we get a "dead object" exception while resetting the markup view;
- the highlighter should use isConnected() first as it checks for the dead object exception;
Assignee: nobody → paul
Attachment #774597 - Flags: review?(dcamp)
Comment on attachment 774597 [details] [diff] [review]
Patch v1

Review of attachment 774597 [details] [diff] [review]:
-----------------------------------------------------------------

Why wasn't this caught by our reloading test?  Can we add a test that does catch it?

::: browser/devtools/framework/toolbox.js
@@ +755,5 @@
>      let outstanding = [];
>  
> +    try {
> +      for (let [id, panel] of this._toolPanels) {
> +        outstanding.push(panel.destroy());

Shouldn't you put the try around each panel.destroy() call, so that all the tools at least have a chance to fail?
Attachment #774597 - Flags: review?(dcamp)
Attached patch Patch v1.1Splinter Review
Addressed comments (includes a test that fails before fix).
Attachment #774597 - Attachment is obsolete: true
Attachment #775507 - Flags: review?(dcamp)
Attachment #775507 - Flags: review?(dcamp) → review+
Duplicate of this bug: 894342
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/7d182fb1c981
Whiteboard: [land-in-fx-team] → [fix
Status: NEW → ASSIGNED
Whiteboard: [fix → [fixed-in-fx-team]
Duplicate of this bug: 894975
https://hg.mozilla.org/mozilla-central/rev/7d182fb1c981
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 25
Verified as fixed on Firefox 25 beta 1, on Ubuntu 13.04 46bit:
Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (20130917123208)
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: ioana.budnar
Hi, 
I think this bug, or a similar type is affecting Firefox Developer Edition 61.0b3 (64-bit).

When I open up the Inspector, it shows the contents of a div just fine, but if I reload the page with the inspector open, whatever div I had selected now shows up as having no contents in the Inspector. 

Is it possible to reopen this bug directed at FFDE or should I create a new one? 

Thanks, and have a great day!
Seems to only happen if I am inspecting something on localhost and changes are made. Not terribly consistent either, which is a huge bummer. Windows 10 Pro
Hi billmalcolm3, this is probably a different bug, since this one here was closed 5 years ago.
If you have a good set of steps someone could follow to reproduce the issue, I suggest opening a new bug at https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&component=Developer%20Tools%3A%20Inspector

By your description of the issue, I think it might be the same problem as bug 1460223 which I have a fix for.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.