Port bug 763181 to TB | 23.0b1 fails to package if configured --with-system-nspr/--with-system-nss/--with-system-sqlite

RESOLVED FIXED in Thunderbird 25.0

Status

MailNews Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gaston, Assigned: gaston)

Tracking

Thunderbird 25.0
x86_64
OpenBSD

Thunderbird Tracking Flags

(thunderbird23 wontfix, thunderbird24 fixed, thunderbird25 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:32: Missing file(s): bin/libnspr4.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:33: Missing file(s): bin/libplc4.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:34: Missing file(s): bin/libplds4.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:56: Missing file(s): bin/libmozsqlite3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:510: Missing file(s): bin/libfreebl3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:511: Missing file(s): bin/libnss3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:512: Missing file(s): bin/libnssckbi.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:513: Missing file(s): bin/libnssdbm3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:514: Missing file(s): bin/libnssutil3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:515: Missing file(s): bin/libsmime3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:516: Missing file(s): bin/libsoftokn3.so.27.0
Error: /home/obj/thunderbird-23.0beta1/build-i386/mail/installer/package-manifest:517: Missing file(s): bin/libssl3.so.27.0

Only some #ifdef MOZ_NATIVE_NSS/MOZ_NATIVE_NSPR/MOZ_NATIVE_SQLITE missing from package-manifest.in. Testing a patch here, seems to affect tb on all branches..
(Assignee)

Updated

4 years ago
status-thunderbird23: --- → affected
status-thunderbird24: --- → affected
status-thunderbird25: --- → affected
(Assignee)

Updated

4 years ago
Summary: TB 23.0b1 fails to package if configured --with-system-nspr/--with-system-nss/--with-system-sqlite → Port bug 763181 to TB | 23.0b1 fails to package if configured --with-system-nspr/--with-system-nss/--with-system-sqlite
(Assignee)

Comment 1

4 years ago
Created attachment 774777 [details] [diff] [review]
Fix c-c packaging with system nss/nspr/sqlite

Fixes packaging for 23.0b1 (using system nss/nspr/sqlite) and c-c tip (using system nspr/sqlite, m-c doesnt build against a released nss since a tls commit)
Assignee: nobody → landry
Attachment #774777 - Flags: review?(mbanner)
Attachment #774777 - Flags: review?(mbanner) → review+
(Assignee)

Comment 2

4 years ago
Comment on attachment 774777 [details] [diff] [review]
Fix c-c packaging with system nss/nspr/sqlite

[Approval Request Comment]
Bug caused by (feature/regressing bug #): packager more strict ?
User impact if declined: failure to package if built w/ system nss|nspr|sqlite
Testing completed (on m-c, etc.): not yet on c-c
Risk to taking this patch (and alternatives if risky): none
Attachment #774777 - Flags: approval-mozilla-beta?
Attachment #774777 - Flags: approval-mozilla-aurora?
Comment on attachment 774777 [details] [diff] [review]
Fix c-c packaging with system nss/nspr/sqlite

I think this is meant for c-c approvals
Attachment #774777 - Flags: approval-mozilla-beta?
Attachment #774777 - Flags: approval-mozilla-aurora?
Attachment #774777 - Flags: approval-comm-beta?
Attachment #774777 - Flags: approval-comm-aurora?
(Assignee)

Comment 4

4 years ago
Oops yeah, my bad.
This is going to mis TB 23 train (but there will be no TB 23) and since its only a thunderbird patch and not a suite patch, I'm not going to triage for SeaMonkey.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/15ad50bcc38d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 25.0
Comment on attachment 774777 [details] [diff] [review]
Fix c-c packaging with system nss/nspr/sqlite

a=me for Aurora, this will get onto beta after the merge today.
Attachment #774777 - Flags: approval-comm-beta?
Attachment #774777 - Flags: approval-comm-beta-
Attachment #774777 - Flags: approval-comm-aurora?
Attachment #774777 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/3c2a49efa00c
status-thunderbird23: affected → wontfix
status-thunderbird24: affected → fixed
status-thunderbird25: affected → fixed
You need to log in before you can comment on or make changes to this bug.