Chart axis labels use poorly-toStringed floats

RESOLVED FIXED

Status

Webtools
Telemetry Dashboard
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 774378 [details]
screenshot

The MIXED_CONTENT_PAGE_LOAD graph ends up with axis labels that look like:

0.60000000000000001%
                0.5%
                0.4%
0.30000000000000004%
                0.2%
                0.1%
                  0%

And then the first few columns get cut off.

Please toString the floats correctly.  Or switch to fixed-point or rational arithmetic, if that makes more sense.

(Viewed with Firefox UX-Nightly on Mac, in case that matters.)

Comment 1

5 years ago
From the screencap, I think this is a bug against the metric owned telemetry dashboards that are being EoL'd this Q. This component tracks the replacement dashboard being developed and hosted at http://telemetry-dash.mozilla.org/. The replacement dashboard does not suffer from this bug.

How would you like to resolve this?
(Reporter)

Comment 2

5 years ago
FIXED / depending on the bug for the switch?

Comment 3

5 years ago
I don't believe there's a bug for handoff. I'm not even aware of an EoL bug from Metrics, really.

Comment 4

4 years ago
The new URL for telemetry dashboards is: http://telemetry.mozilla.org/

The Metrics dashboards have been EOL'd, and logging in at the old URL (metrics.mozilla.com) now redirects to the above URL.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.