Disable font-inflation on netError pages

RESOLVED DUPLICATE of bug 903327

Status

()

RESOLVED DUPLICATE of bug 903327
5 years ago
5 years ago

People

(Reporter: wesj, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The try again button on net error pages has gotten really tiny. I assume we're using font-inflation there now? We should disable it on these pages.
Should we disable it on any viewport metatag page?
Do we allow zooming on these pages at all? If not, then we should certainly be disabling font inflation.
(Reporter)

Comment 3

5 years ago
No. Maybe this is a recent change in content.css that had an unexpected consequence.
(In reply to Wesley Johnston (:wesj) from comment #3)
> No. Maybe this is a recent change in content.css that had an unexpected
> consequence.

Alternatively, we could add -moz-text-size-adjust: none to the css styles of these pages that we don't want font inflation enabled for.
(Reporter)

Comment 5

5 years ago
I looked, and text-inflation actually IS disabled on error pages, but for some reason fonts are still drawing themselves crazy small on buttons there. I fixed it in the new error pages by adding:

button { font-size: 1rem; }

in the css. I'm not sure what's up here. If its font-inflation or some other css overriding us somewhere? Need someone to dig more. Maybe look for a regression date.
(Reporter)

Comment 6

5 years ago
I think this is a dup and was fixed in bug 903327.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903327
You need to log in before you can comment on or make changes to this bug.