Protobuf fails to build in VS 2013

RESOLVED FIXED in Firefox 28

Status

()

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: xavier114fch, Assigned: emk)

Tracking

Trunk
mozilla28
x86
Windows 8
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox28 fixed)

Details

(Whiteboard: [qa-], )

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

6 years ago
Add missing include for successful building on VS 2013.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Build Config → General
Posted patch import r512Splinter Review
Attachment #774465 - Attachment is obsolete: true
Attachment #823237 - Flags: review?(mmc)
Comment on attachment 823237 [details] [diff] [review]
import r512

Review of attachment 823237 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.
Attachment #823237 - Flags: review?(mmc) → review+
Assignee: nobody → m_kato
https://hg.mozilla.org/mozilla-central/rev/c7c4e8463dc3
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Assignee

Comment 6

6 years ago
Still fails to build...

78:14.00 wire_format_lite.cc
78:14.00 h:\m\mozilla-central\toolkit\components\protobuf\google/protobuf/wire_f
ormat_lite_inl.h(270) : error C3861: 'min': 識別子が見つかりませんでした
78:14.00         h:\m\mozilla-central\toolkit\components\protobuf\google/protobu
f/wire_format_lite_inl.h(303) : コンパイルされたクラスの テンプレート のインスタ
ンス化 'bool google::protobuf::internal::WireFormatLite::ReadRepeatedFixedSizePr
imitive<google::protobuf::uint32,TYPE_FIXED32>(int,google::protobuf::uint32,goog
le::protobuf::io::CodedInputStream *,google::protobuf::RepeatedField<google::pro
tobuf::uint32> *)' の参照を確認してください
78:14.02 Native command 'mozbuild.action.cl main' returned value '2'
78:14.13 945 compiler warnings present.
2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This last patch worked for me.
Xavier, can you please update the file r512.patch introduced in https://bugzilla.mozilla.org/page.cgi?id=splinter.html&bug=892856&attachment=823237?

Otherwise, looks good to me.

Thanks,
Monica
Assignee

Comment 10

5 years ago
Protobuf no longer fails build in unified mode.
(In reply to Masatoshi Kimura [:emk] from comment #10)
> Protobuf no longer fails build in unified mode.

This was also WFM in my local unified build.
Assignee

Comment 12

5 years ago
We still need this for non-unified builds.
Assignee: m_kato → VYV03354
Attachment #827664 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
Attachment #8361777 - Flags: review?(mmc)
Attachment #8361777 - Flags: review?(mmc) → review+
https://hg.mozilla.org/mozilla-central/rev/011815b28db2
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.