Closed Bug 892900 Opened 6 years ago Closed 6 years ago

Can't use asyncStorage in Private Browsing windows - fails with InvalidStateError

Categories

(Firefox :: Private Browsing, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 781982

People

(Reporter: sole, Unassigned)

Details

Attachments

(1 file)

Please see the test case. Instead of getting a 'null' result because we haven't stored the value yet, we get an InvalidStateError and that's it.

It works fine in 'normal' browsing mode

I'm using the latest Nightly (20130711)
Happens on latest Beta too.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781982
You need to log in before you can comment on or make changes to this bug.