Explain that inviting someone to create a profile automatically vouches that user

VERIFIED FIXED

Status

--
enhancement
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: sandeep.b, Assigned: giorgos)

Tracking

Details

(Whiteboard: [invite-vouched][vouching rel. 1])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22

Steps to reproduce:

1. Signed into Mozillians as vouched user.
2. Clicked on "Invite" from the user dropdown menu.
3. Typed in an email address in the Recipient field and clicked on Send Invite.
4. The particular recipient's email got a mail containing a link clicking on which, I was led to the Mozillians homepage.
5. Signed up using Persona, verified the email address and completed the account registration by filling up details.


Actual results:

I could see that the account had already been vouched.


Expected results:

Inviting a person to Mozillians could be provided with the functionality of only introducing the Mozillians site to the person and helping him create an account. Vouching the person should happen only after a proven contribution to Mozilla.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement
Sandeep, thanks for filing this bug! You make a great observation, and that behavior is actually by design. To make this more clear, I suggest we update the string at the top of the invite form.

Current string: "If you'd like to invite a Mozillian to create a profile, please enter their email address here:"

Suggested new string: "If you'd like to vouch for someone as a core Mozilla contributor and invite them to create a profile, please enter their email address here:"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Phonebook :: Invite :: Inviting a person to Mozillians vouches for him. → Explain that inviting someone to create a profile automatically vouches that user
Whiteboard: [invite-vouched]
(Assignee)

Updated

4 years ago
Blocks: 926644
(Assignee)

Comment 2

4 years ago
Fixed in 78359533b6d89d18783ddb24411f91d0c7f9b718

We now display the vouch form and we link to the vouching faq.
Assignee: nobody → giorgos
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Whiteboard: [invite-vouched] → [invite-vouched][vouching rel. 1]
Verified on dev as stated in comment 2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.