Commas in file names replaced with %2C in the download dialog

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: srikar, Unassigned)

Tracking

21 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 774611 [details]
Bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

I changed the Downloads to "Always ask me where to save" 


Actual results:

When I downloaded a file which has "," in the file name, Firefox shows this can be saved as "%2C" instead of ","
Example: If the File name is abcd,ghi it should be saved as abcd,ghi instead it shows save it as "abcd%2Cghi"


Expected results:

Example: If the File name is abcd,ghi it should be saved as abcd,ghi instead it shows save it as "abcd%2Cghi"
(Reporter)

Updated

5 years ago
Duplicate of this bug: 892952

Comment 2

5 years ago
I can't reproduce: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:25.0) Gecko/20130625 Firefox/25.0

Could you please try to reproduce in a recent nightly?

Downloads originate in nsExternalAppHandler, so moving to Core::File Handling for further investigation, but maybe it's a URI-handling problem for Core::Networking.
Component: Untriaged → File Handling
Product: Firefox → Core
Summary: Downloads saving "," as "%2C" → Commas in file names replaced with %2C in the download dialog
(Reporter)

Comment 3

4 years ago
Its working fine now with latest version of firefox :) This can be closed.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.