"open link in new window" on google ad opens in both the old window and a new window

RESOLVED DUPLICATE of bug 71705

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 71705
17 years ago
14 years ago

People

(Reporter: eric, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

Did a search at google for "Faux Wood Blinds" The search results 
included several sponsored links  listed in a column on the right
side of the search results page. Right clickin on one of those links
and selecting "Open Link in New Window" Causes the page to open and
load in a new window, but it also loaded the page in the search results
window.

I then did a search for "Cars" and got the other style sponsored link which
appears above the search results. Trying to open this link in a new window
exhibited the same behavior.

Opening the actual search results in a new window works fine. 

Reproducible: Always
Steps to Reproduce:
1.www.google.com
2.Search for "Faux Wood Blinds"
3. Right click on the sponsored link for JustBlinds.com and select to open in a
new window

Actual Results:  www.justblinds.com loaded in both a new window and my search
window.

Expected Results:  www.justblinds.com should have only loaded in the new window

to get around, I still use the open link in new window, then I have to hit
'Back' in the original window to get back to the page I was on

Comment 1

17 years ago
Created attachment 41211 [details]
e-mail I sent to google last december

Comment 2

17 years ago
I'm tempted to say that this is entirely Google's problem, since a similar 
problem happens with Internet Explorer, but see bug 71705 and bug 86193.

Comment 3

17 years ago
Another site exhibits the same problem:
http://www.anandtech.com/ then open in a new window by right-clicking (or
middle-clicking) one of the 'News' (not Site News) in the left-bottom table.
It'll open page both in main window and in the new window.
This is with build 2001090703 on Win2k.

Comment 4

17 years ago
Created attachment 48697 [details]
Example of link found on anandtech.com

Comment 5

17 years ago
Marking duplicate as this is described in bug 71705 with the URL
http://www.google.com/search?q=auto+buy

*** This bug has been marked as a duplicate of 71705 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
WFM with:
- Right+clicking in IE, Opera, Mozilla
- Middle-clicking in Mozilla

Still happens with:
- Ctrl+clicking in Mozilla
- Shift+clicking in IE
- Shift+clicking and Ctrl+Shift+clicking in Opera

Updated

16 years ago
Summary: Using the context menu to open a sponsored link in a new window causes the link to be loaded in both the old window and a new window → "open link in new window" on google ad opens in both the old window and a new window

Comment 7

16 years ago
*** Bug 151833 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 150853 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
We could stop sending ctrl+click-on-link events to pages (bug 151142).  That 
would break some sites, but it would make ctrl+clicking consistent with "open 
link in new window/tab", which already breaks those sites.

Comment 10

16 years ago
*** Bug 141405 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.