Rendering error with text-align:center and 100% Width

RESOLVED DUPLICATE of bug 243412

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 243412
4 years ago
4 years ago

People

(Reporter: Aaron Marasco, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 774643 [details]
demo.html

User Agent: Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.16

Steps to reproduce:

See attached file - this is a CSS rendering bug.


Actual results:

Child elements are not centered in the parent elements.


Expected results:

See attached file - it's expected that this will render with all child elements of the "li" centered in a minimum 100px "li". The child element should take up the full width of the parent, with minimum 20px padding on each side.

Comment 1

4 years ago
I think it is necessary to add -moz- prefix for box-sizing;
( https://developer.mozilla.org/en-US/docs/Web/CSS/box-sizing#Notes )

Updated

4 years ago
Component: Untriaged → Layout
Product: Firefox → Core
Attachment #774643 - Attachment mime type: text/plain → text/html
Yep.  We don't support unprefixed box-sizing yet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243412
You need to log in before you can comment on or make changes to this bug.