Remove version number from ESR nightly update channel

RESOLVED WONTFIX

Status

Release Engineering
General Automation
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-automation-wanted])

(Reporter)

Description

4 years ago
Currently the update channel for ESR is esr17-nightly. Could we remove the version number and simply have esr-nightly? This would mean that nightly users would be updated across major ESR versions, and we wouldn't need to change the number each time.
Are ESR nightlies actually supported in any way? AFAIK we only do nightly builds for regression range purposes.
Assignee: server-ops-releng → nobody
Component: Server Operations: RelEng → Release Engineering: Automation (General)
QA Contact: arich → catlee
Exactly that's why we have requested ESR nightly builds, and run our Mozmill tests against those. All what we want is to find regressions as early as possible, and not when RC builds are available for the next ESR release. This also includes update tests.
Reiterating what Henrik has said here, our automation is not just about "support", it's about getting early warning for regressions. Finding out about regressions once we get to RC is too late.
Whiteboard: [qa-automation-wanted]
(In reply to Dave Hunt (:davehunt) from comment #0)
> Currently the update channel for ESR is esr17-nightly. Could we remove the
> version number and simply have esr-nightly? This would mean that nightly
> users would be updated across major ESR versions, and we wouldn't need to
> change the number each time.

Just to add, this would be similar to the release channel which is 'esr' and 'esrtest'. Not sure why we have introduced the version number in the channel name.
I think the version number was introduced because we overlap support for 2 release cycles on ESR. In other words, there's a 12 week period where we maintain two separate ESR versions.
Sure, but during the same time we also have two releases and there is no version number in the update channel. It's just 'esr' and 'esrtest'.
Anthony is right about the 12 week overlap leading to the separate channel names, and because logically they are separate branches. We don't need the channel to be nightly-esr for us to update users from 10 -> 17 -> 24, as there's enough flexibility in the update server to map requests wherever we like. Is there some other benefit here ?

BTW, there are about 8K people on nighty-esr10, and less than a hundred on nightly-esr17 (might be a metrics bug there?). We should consider sending the esr10 people to esr17. This got missed when we did the esr channel in bug 802167.
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
I don't think there's any benefit to doing this. The versioned channel names can be used to test ESR updates already.

We haven't (and likely don't want to) do cross esr branch nightly updates.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Meanwhile we also removed the list of allowed update channels, and keep a free form option for our automation scripts. So we only have to change the channel name when we create new jobs in mozmill-ci, but no longer in mozmill-automation. So I think that is manageable from our side.
You need to log in before you can comment on or make changes to this bug.