Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1195692
5 years ago
2 years ago

People

(Reporter: wesj, Unassigned, Mentored)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=java])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
We created alert notification awhile ago to handle custom progress indicators in Alerts. This was later added as a platform ability and (I think?) back ported to work on older platforms through the compatability layer.

At this point, I think we can remove AlertNotification and instead switch to using Notification.Builder:
http://developer.android.com/reference/android/support/v4/app/NotificationCompat.Builder.html
(Reporter)

Updated

5 years ago
Whiteboard: [mentor=wesj][lang=java]

Comment 1

5 years ago
Hello, 

I am a complete newbie to open source software, and I was wondering if you could tell me how to get started. I have a working knowledge of Java, and would love to help however possible. I am also currently learning Objective C and iPhone development. Please point me in the right direction!

Thanks a lot!

Comment 2

5 years ago
(In reply to Arjun Nijhawan from comment #1)
> Hello, 
> 
> I am a complete newbie to open source software, and I was wondering if you
> could tell me how to get started. I have a working knowledge of Java, and
> would love to help however possible. I am also currently learning Objective
> C and iPhone development. Please point me in the right direction!
> 
> Thanks a lot!

Welcome! The first thing you should do is set up a build environment. You should follow the directions here:
https://wiki.mozilla.org/Mobile/Fennec/Android

After you do that, wesj can help advise you on how to approach this bug. Feel free to join #mobile on irc.mozilla.org to ask questions (or just to hang out). There are also some handy links on this page:
https://wiki.mozilla.org/Mobile/Get_Involved

Comment 3

5 years ago
Hello, 

I hope I'm not taking up valuable time here, but I don't really understand how the build works. Do I just copy and past the code from the build instructions into Terminal? I have no experience with Terminal commands, and I'm not really sure if I'm doing anything correctly.Could you point me to some resources, or tell me what I should learn before attempting this? 

Thanks!

Comment 4

5 years ago
Just some further information: I have XCode all set up, and I am familiar with it since I develop iOS applications, but I can't seem to understand the instructions after that.
(Reporter)

Comment 5

5 years ago
Sorry for the delay. Yes, you should just be able to follow the instructions here:

https://wiki.mozilla.org/Mobile/Fennec/Android#Mac_OS_X

I would not try to use XCode for this. The Firefox build system doesn't integrate well with IDE's. I have a feeling it will get in the way. In fact, if you're very new to developing like this, I'd recommend building desktop Firefox first:

https://developer.mozilla.org/en-US/docs/Simple_Firefox_build

Those instructions are quite a bit easier to follow, and once you've got that done, Fennec is just a few extra steps on top of it.
(Reporter)

Comment 6

5 years ago
Created attachment 782218 [details] [diff] [review]
WIP

I'd also say, I can mentor on this bug, but its not a great first bug for new contributors. This is a WIP I had to do this. Its mostly done but needs testing on some different devices.

I glanced through bugsahoy and didn't see a ton of good "find your way around the code" bugs, so I'll try to make some time monday to look through the backlog for things.

Comment 7

5 years ago
I think this bug is related if not duplicate of bug 909932
(Assignee)

Updated

4 years ago
Mentor: wjohnston@mozilla.com
Whiteboard: [mentor=wesj][lang=java] → [lang=java]
See Also: → bug 1195692
AlertNotification has been killed in bug 1195692.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1195692
You need to log in before you can comment on or make changes to this bug.