If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sign up button is not working of student ambassadors page

VERIFIED FIXED

Status

www.mozilla.org
Pages & Content
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Swarnava, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
go to

http://www.mozilla.org/en-US/contribute/universityambassadors/

fill the form and click on the sign me up button

its not working
Thanks for reporting.

Team - this isn't working for me either.

Comment 2

4 years ago
Confirmed that it is not working for me.

Comment 3

4 years ago
Alex: It looks like you were the last person to work on this form and it is broken now. Not sure if a recent push broke something that this form is using.
PR here: https://github.com/mozilla/bedrock/pull/1068

Looks like this bug is a result of commit: https://github.com/mozilla/bedrock/commit/b6eed50f1f0757757721cd953b2a136194d111b2#media/js/base/footer-email-form.js

Simplest fix was to change the id of the ambassadors page form, since (I'm assuming) it was originally taken from the contribute page template, and hence had the same id.

Comment 5

4 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/a58f31a1b3dfb96b20abfbe2fa823063fdaec349
sign up button is not working of student ambassadors page bug 893329

Comment 6

4 years ago
Please let us know when/where this is ready to be tested.
Hi all:
Any thoughts on when this will be fixed? I've received a couple of pings about it already from potential members and I want to be sure to update them with the approximate date when they will be able to sign-up. Also, anything else you need from me here? Thanks!
Hopefully going out within the hour. Already fixed on stage:

https://www.allizom.org/en-US/contribute/universityambassadors/

Comment 9

4 years ago
Created attachment 775939 [details]
error

Got a weird error on stage: "Input error: k: Format of site key was invalid"
(In reply to Jessilyn Davis from comment #9)
That's the captcha, it's broken on stage.

Comment 11

4 years ago
Ah - cool - let us know when it goes live so we can test fully there.

THanks!
This is on stage but we can only test when it goes to production due to the fact that reCAPTCHA is broken on stage.
This is on prod now. WFM.

Also we could test the bug on stage, because the bug was the the submit button wasn't doing anything. I confirmed that after the change the submit button attempted to submit the form b/c I could see the form field validation kick in. We didn't need to fully test submission of this form in order to test the fix as the fix was purely client side.

I'm working on getting stage captchas fixed in bug 788690.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 14

4 years ago
Raymond, can you test prod today?

Scenarios to test:

1) Sign up just for Student Ambassadors (don't check any other subscriptions) - make sure you get the welcome email in the right format, and when you go to your /existing (email pref center) you have just that flag chosen


2) Sign up for Student Ambassadors + other newsletters - make sure you get the welcome emails in the right format, and when you go to your /existing (email pref center) you have the right flags chosen


3) Make sure you show up in the STUDENT_AMBASSADORS data extension. You can send me your email addresses to check, or you/Rebecca can check by using the "Individual Email Lookup Student Ambassadors" query in ET.
fixed on prod https://www.mozilla.org/en-US/contribute/universityambassadors/thanks/#ambassadors-form
Status: RESOLVED → VERIFIED

Comment 16

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/3b984011f7d18ceeb86d1a5a55ecee702c79c64c
Adjust Russian tabzilla promo font size bug 893329

https://github.com/mozilla/bedrock/commit/bac61d7d8d791773ec9248f94ea9ef8485e41702
Merge pull request #1081 from alexgibson/adjust-russian-tabzilla-promo-text-size-bug-869004

Adjust Russian tabzilla promo font size bug 893329
Whoops I must have added the wrong bug number to that pull request in comment 16, sorry.
Just tested and form works for me! Can I let everyone know it's been fixed? Thanks! Kate

Comment 19

4 years ago
Yep! It's been verified that it's fixed. Alert away :)
Awesome - thanks all for your help here!
(Reporter)

Comment 21

4 years ago
Yes its working fine now

Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0
You need to log in before you can comment on or make changes to this bug.