Closed Bug 893330 Opened 7 years ago Closed 7 years ago

Funny thing happens when a single div uses both box-shadow and border-radius, and change positions

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: timdream, Assigned: nrc)

Details

Attachments

(3 files)

Attached file Testcase
Sorry for the non-descriptive summary, but you will get the idea when trying out the test case . I suspect this is a dup too coz it's very easy to reproduce.

Expected result:
a div rendered as a circle moved by setInterval()

Actual result:
the div itself doesn't seems to be updated, and the shadow and border of the previous position remains.

Real world example:
http://timdream.org/wordcloud2.js/#web-tech and hover the mouse over the canvas.
I would put a small amount of money on this being a mask layers bug. We should add a pref for mask layers so this is easy to test. Does using a box-shadow do something interesting to the layers?
(In reply to Nick Cameron [:nrc] from comment #1)
> I would put a small amount of money on this being a mask layers bug. We
> should add a pref for mask layers so this is easy to test. Does using a
> box-shadow do something interesting to the layers?

Well, turns out it is not a mask layer bug at all. There are no mask layers created for this test case.
Component: Graphics: Layers → Graphics
QA Contact: ncameron
Assignee: nobody → ncameron
QA Contact: ncameron
My current working theory is that we are not resetting a clip after drawing a box shadow and so we end up not overdrawing the frame.

It seems that the problem is here without border radius too, but in that case we are overdrawing just what we are drawing, so we don't see it.
Turns out all my theories were wrong. It is an invalidation issue (I think). Patch coming up...
Attached patch patchSplinter Review
Attachment #794379 - Flags: review?(matt.woodrow)
Comment on attachment 794379 [details] [diff] [review]
patch

Review of attachment 794379 [details] [diff] [review]:
-----------------------------------------------------------------

Nice
Attachment #794379 - Flags: review?(matt.woodrow) → review+
Needs a test!
Flags: in-testsuite?
Attached patch reftestSplinter Review
Attachment #794416 - Flags: review?(matt.woodrow)
Attachment #794416 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/d9f853609281
https://hg.mozilla.org/mozilla-central/rev/9802d4d9a79a
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.