new mozilla windows lose URL bar, menus, personal toolbar

VERIFIED DUPLICATE of bug 95000

Status

SeaMonkey
Location Bar
VERIFIED DUPLICATE of bug 95000
17 years ago
10 years ago

People

(Reporter: Anthony Baxter, Assigned: Joe Hewitt (gone))

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build 2001-07-04-08 on Redhat Linux 7.1. After not very long of browsing, 
moz goes into a mode where all new windows come up busted - empty URL bar, 
empty page. Entering something into the URL bar brings up the URL bar 
history, but I can't getit to actually load the page. 
The personal toolbar buttons (including Home) don't work, the menu entries
to do with going to a new page (e.g. Go->Home, Bookmarks) don't work. 
Interestingly, the links in QA work, but the URL bar stays blank.Once I can
get a page loaded, I can then browse from links in the page, but the URL bar
and personal toolbar remain busted.

The original window continues to work fine - just no new windows are sane.
Restarting fixes this.
No error or debug is printed out - if someone wants to suggest debugging
that I can do, let me know.
(Reporter)

Comment 1

17 years ago
Oh, excellent. Now I can't even get them back after a restart.
Will try nuking my profile and see if that fixes it.
I also tried upgrading to 2001-07-04-08. 

Wah. I want my url bar and personal toolbar back.
(Reporter)

Comment 2

17 years ago
Created attachment 41394 [details]
localstore.rdf, cut down to just the broken lines.
(Reporter)

Comment 3

17 years ago
Ok, I did a quickie hack script to stomp through the RDF til I figured out
what was causing the problems. It seems like the sections:
  <RDF:Description 
about="chrome://navigator/content/navigator.xul#PersonalToolbar"
                   moz-collapsed="true"
                   hidden="false" />
  <RDF:Description 
about="chrome://navigator/content/navigator.xul#nav-bar"
                   moz-collapsed="true"
                   hidden="false" />
caused the personal toolbar and navbar to Just Go Away. No little thumb or
whatever you call it to bring it back, or anything... Removing the
'moz-collapsed="true"' bit makes them come back. I've attached a localstore.rdf
that just has the broken lines. I don't know how or why these lines got into
the localstore.rdf. I was trying to figure out a way to reproduce the broken
URL bar and toolbar, and tried collapsing a broken one. It Went Away, and 
wouldn't come back.

Comment 4

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 5

17 years ago
I'm pretty sure this is the same as bug 95000.

Comment 6

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross

Comment 7

17 years ago
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt
(Assignee)

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 95000 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.