If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lost prefs.js during system crash due to missing fsync

RESOLVED INVALID

Status

()

Core
Preferences: Backend
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Octoploid, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20130712165549

Steps to reproduce:

I was debugging a Linux system crash in the last few days.




Actual results:

During the crash tests I lost prefs.js several times
(xfs filesystem journal recovery deleted it).


Expected results:

It looks like a missing fsync call causes the data loss 
and nsISafeOutputStream isn't so "safe" at all.

prefs.js is a critical file and data safety trumps performance in this case IMO.
(Reporter)

Comment 1

4 years ago
Turned out to be a xfs bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Comment 2

4 years ago
Thanks for following up!
You need to log in before you can comment on or make changes to this bug.