Firefox 22 embed tag: hidden = true disables media

RESOLVED DUPLICATE of bug 890516

Status

()

defect
RESOLVED DUPLICATE of bug 890516
6 years ago
6 years ago

People

(Reporter: zweigmedia, Unassigned)

Tracking

22 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Place any <embed> sound tag in a Web page, and set 'hidden' to "true".

For instance, <embed src="----" autostart="true" loop="false" hidden="true" height="20" width = "180"></embed>

See http://www.zweigmedia.com/FirefoxEmbedBug.html for an actual example showing effect of the same tag with and without the "hidden" attribute.




Actual results:

No sound plays (starting in Firefox 22).


Expected results:

Sound should play, but the sound controller should be invisible.

Workaround: Remove the "hidden" attribute and enclose the <embed>---</embed> in a container with style="visibility:hidden".

Comment 1

6 years ago
Posted file 56k.swf

Comment 2

6 years ago
I uploaded a version of your testcase with SWF file, so it runs fine with Flash Player instead of requesting this useless QT plugin to play the WAV file.

Comment 3

6 years ago
In addition, I read another report about this issue on a French Mozilla board, so there is likely a regression (or a valid change maybe).

A possible workaround is to use better HTML5 tags like <audio>/<video> with autoplay and {display: none;}.
Reporter

Comment 4

6 years ago
So let me amend the report to say that, for Firefox 22 browsers not using Flash player to render audio, this is an issue (and is not an issue in earlier versions of FF, nor is it an issue in other browsers).

By the way, this is not a purely QT issue, as there are also reports that the same bug effects media rendered with NPAPI:

https://blog.mozilla.org/addons/2013/06/03/compatibility-for-firefox-22/

Comment 5

6 years ago
Recently fixed in FF25.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890516
You need to log in before you can comment on or make changes to this bug.