All users were logged out of Bugzilla on October 13th, 2018

system crash while displaying background GIF at americanexpress.com

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: paul_gregg, Assigned: pavlov)

Tracking

(4 keywords)

Trunk
x86
Windows NT
crash, stackwanted, testcase, top100
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Found while testing with chofmann's browser buster [test_url_25.html] (got to
page 64)...     ...and then hit http://americanexpress.com/

The background GIF image at the URL location (I will attach shortly) crashes
Mozilla and NT system (even mouse hangs) 100% of time.
Offending image "http://www.americanexpress.com/homepage/images/bkg.gif"
10x3000x256color GIF LZW
Cannot reproduce on another NT PC (has different video card - ATI 3D Rage Pro).

System config:
WIN NT4 sp6, ie5.5sp1, ntfs, PIII550 128mb ram, relatively clean install.
Video S3 Trio 3D/2X 4mb, display driver version 3.30.05, 16.7million colors,
1152x864

Appears to get stuck on the background image only, here's my steps in testing
(using talkback builds, but system hangs, don't know how to get any info here..)

* Using 0.9.2 build
* Appears to almost load and render complete page = hang
* Made a local copy with images  = hang
* Tried page without images = fine
* Tried displaying all images seperately = hang on bkg.gif image only
* removed bkg.gif from local copy = fine
* Nightly 2001062004 = hang
* New nightly 2001070204 = hang
* ^^ nighlty with new profile = hang
* ^^ WinEmbed = hang
* ^^ Viewer = hang
* IE5.5 sp1 = fine
* IrfanView image viewer v3.36 = fine
* Try different themes & view image = hang
* Try 0.8 release 20010215 (old imglib) = hang
* ^^^^^^^ build using Viewer = hang
* M10 build (viewer) = hang
  (displays in Title 'Image 10x3000' so it is parsing some of it - thinking
rendering problem maybe)
* Thought I'd give NN4.77 a go = HANG!!!!

Thats not good...

Paul Gregg
(Reporter)

Comment 1

18 years ago
Created attachment 41240 [details]
Offending image
(Reporter)

Comment 2

18 years ago
Image is now attached....
Moving Priority to P5 because:
 * Appear to affect only certain video cards
 * Only happens on this site (main browser for months of surfing)
 * Not just limited to Moz (NN as well, but not IE)

Could there be image code from NN thats in Moz that causes this, I thought there
was a complete rewrite (maybe even twice)
Keywords: crash, testcase, top100
Priority: -- → P5

Comment 3

18 years ago
works for me with no problems, the url and the attachment makes no poblems
build 2001070404 on winnt
1024x768 true color with creative labs tnt 2 ultra. driver: v4.03.00.2111-01.208

Comment 4

18 years ago
WFM loading the image into the browser of Win32 nightly build 2001070406.

Comment 5

18 years ago
Resetting priority. We need a stacktrace here.
Severity: normal → critical
Keywords: stackneeded
Priority: P5 → --
(Reporter)

Comment 6

18 years ago
Looked up stackneeded on Mozilla.org, newsgroups & internet, nothing (other than
the keyword definition).
Question is how do I get a stack trace for a bug that causes the system to hang?
I think I would need a debug build along the way, how do we get these (heard
something about ftp:nightly/experimental/ but no window builds.

PS. I'll be glad to do as much running around as need be, just point me in the
right direction.
PPS. Not surprised by the WFM's since it appears specific to the video card (or
maybe a family of S3 cards)

Comment 7

18 years ago
In order to get a debug build you need to compile it yourself with the debug
flag turned on. See http://www.mozilla.org/build/

Comment 8

18 years ago
Reporter: Try duplicating the bug without any background processes running.
Mozilla has known crash and lockup issues with certain other programs.
(Reporter)

Comment 9

18 years ago
Build 2001071604

Listed below are the only processes running on the computer (via TaskManager)
No visible applications other than Moz are running

SMSS.EXE
CSRSS.EXE
WINLOGON.EXE
SERVICES.EXE
RPCSS.EXE
LSASS.EXE
SPOOLSS.EXE
ZipToA.exe
PSTORES.EXE
mstask.exe
EXPLORER.EXE
systray.exe
PROMon.exe
LOADWC.EXE
TASKMGR.EXE
mozilla.exe

Comment 10

18 years ago
Again:

Reporter: Try duplicating the bug _without_ any background processes running.
Mozilla has known crash and lockup issues with certain other programs.
(Reporter)

Comment 11

18 years ago
Ummm, not sure if you have used NT4 before, but the list I gave listed all
processes running, including system processes.  I killed all processes I could
(NT won't let you kill some processes), and my user account has admin privileges!
The only non-normal ones were mozilla.exe (duh), ZipToA.exe (Zip drive) and
PROMon.exe (Intel network card driver).

BTW. (A different machine)......
====================
WFM  Win2000 SP2, ie5.5sp1, ntfs, PII400 128mb ram, relatively clean install.
Video S3 Trio 3D/2X 4mb, display driver version 5.30.05, true color, 1152x864
====================
FWIW, the attachment does not crash my PC/Linux debug build from 8/17.

Comment 13

17 years ago
wfm on Win2k with build 2001090703 and ATI Radeon VE with driver v.5.13.01.3211
(desktop 1280x1024 32 bits).

Comment 14

17 years ago
Marking WORKSFORME based on comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
Verified w2k build 2001-09-10-05-trunk
Status: RESOLVED → VERIFIED

Comment 16

10 years ago
Crashtest added as part of http://hg.mozilla.org/mozilla-central/rev/5a6def05ccbc
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.