If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unused variables in MIR.cpp at line 1584

RESOLVED DUPLICATE of bug 893904

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 893904
4 years ago
4 years ago

People

(Reporter: anba, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Remove line 1584 in ion/MIR.cpp:
> MDefinition *newlhs, *newrhs;

"newlhs" and "newrhs" are both unused, looks like a copy'n paste error, see tryUseUnsignedOperands().
(Reporter)

Updated

4 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893904
You need to log in before you can comment on or make changes to this bug.